aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-raspell/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-11-11 01:40:10 +0800
committerknu <knu@FreeBSD.org>2002-11-11 01:40:10 +0800
commitde9be80671b10992646a40dd984f79d5710f7636 (patch)
treeaacec545d9491b5cbb6de89a8b9fc7128009d94e /textproc/ruby-raspell/Makefile
parentc8361b41ff7bac37a272a9c3f7955946ddec8292 (diff)
downloadfreebsd-ports-gnome-de9be80671b10992646a40dd984f79d5710f7636.tar.gz
freebsd-ports-gnome-de9be80671b10992646a40dd984f79d5710f7636.tar.zst
freebsd-ports-gnome-de9be80671b10992646a40dd984f79d5710f7636.zip
Add ruby-raspell, a Ruby interface binding to aspell.
Diffstat (limited to 'textproc/ruby-raspell/Makefile')
-rw-r--r--textproc/ruby-raspell/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/ruby-raspell/Makefile b/textproc/ruby-raspell/Makefile
new file mode 100644
index 000000000000..aa2c83e3ac9c
--- /dev/null
+++ b/textproc/ruby-raspell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rAspell
+# Date created: 10 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= raspell
+PORTVERSION= 0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.rb ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>