aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-rss.alt/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-03-23 16:45:41 +0800
committerknu <knu@FreeBSD.org>2003-03-23 16:45:41 +0800
commita0fc56a8f3603cf9494ccecb24c018144100a94b (patch)
tree2f6aa05e196d64849c849d57468d82fc2fac27cc /textproc/ruby-rss.alt/Makefile
parentecc18996eab4c00185c40baec589c2f7ba479a93 (diff)
downloadfreebsd-ports-gnome-a0fc56a8f3603cf9494ccecb24c018144100a94b.tar.gz
freebsd-ports-gnome-a0fc56a8f3603cf9494ccecb24c018144100a94b.tar.zst
freebsd-ports-gnome-a0fc56a8f3603cf9494ccecb24c018144100a94b.zip
Add ruby-rss.alt, a Ruby library for handling RSS (alternative impl.).
Diffstat (limited to 'textproc/ruby-rss.alt/Makefile')
-rw-r--r--textproc/ruby-rss.alt/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/textproc/ruby-rss.alt/Makefile b/textproc/ruby-rss.alt/Makefile
new file mode 100644
index 000000000000..973262121056
--- /dev/null
+++ b/textproc/ruby-rss.alt/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/RSS (alternative impl.)
+# Date created: 23 March 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rss
+PORTVERSION= 0.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://cozmixng.sgk.iwate-u.ac.jp/~kou/download/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+PKGNAMESUFFIX= .alt
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby library for handling RSS (alternative impl.)
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv \
+ ${RUBY_SITELIBDIR}/xmlscan/parser.rb:${PORTSDIR}/textproc/ruby-xmlscan
+# You can use REXML as an alternative to xmlscan, but 2.5.0 or later only:
+# ${RUBY_SITELIBDIR}/rexml/document.rb:${PORTSDIR}/textproc/ruby-rexml
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS_EN= README.en Tutorial.en
+DOCS_JA= README.ja Tutorial.ja
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>