aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-sary
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
committerknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
commit584984a14cadb1bedf9e267effdafd4aac178618 (patch)
tree27e9d2d6bee9a8d90b9da0364a0514d6acc23097 /textproc/ruby-sary
parentbb4b58c482c462fe675e9cc2b457369555b0b634 (diff)
downloadfreebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.tar.gz
freebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.tar.zst
freebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.zip
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'textproc/ruby-sary')
-rw-r--r--textproc/ruby-sary/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/ruby-sary/Makefile b/textproc/ruby-sary/Makefile
index c6a7890bc9ec..863e8d3f08fe 100644
--- a/textproc/ruby-sary/Makefile
+++ b/textproc/ruby-sary/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sary
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc ruby
MASTER_SITES= http://prime.sourceforge.jp/freebsd/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,8 +22,6 @@ LIB_DEPENDS= sary.9:${PORTSDIR}/textproc/sary
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_WITH_PTHREAD= yes
-
INSTALL_TARGET= site-install
RUBY_RD_FILES= *.en.rd *.ja.rd
@@ -34,10 +32,15 @@ DOCS_EN= ChangeLog \
DOCS_JA= ${RUBY_RD_FILES:M*.ja.rd} \
${RUBY_RD_HTML_FILES:M*.ja.html}
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
+
post-install: doc-install
${INSTALL_SCRIPT} ${WRKSRC}/rsary.rb ${PREFIX}/bin/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
doc-install:
.if !defined(NOPORTDOCS)