aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-xslt/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-08-22 16:40:33 +0800
committerknu <knu@FreeBSD.org>2001-08-22 16:40:33 +0800
commit75c89a7b35549fdba26158a8125fdbd74d83ff86 (patch)
tree5b9be795773ebdd10c69e459b2b53c3a013ed939 /textproc/ruby-xslt/Makefile
parent0287139b0ae0b3a873bf03fb6d64f279797fc0a7 (diff)
downloadfreebsd-ports-gnome-75c89a7b35549fdba26158a8125fdbd74d83ff86.tar.gz
freebsd-ports-gnome-75c89a7b35549fdba26158a8125fdbd74d83ff86.tar.zst
freebsd-ports-gnome-75c89a7b35549fdba26158a8125fdbd74d83ff86.zip
Add ruby-xslt, an XSLT processor in pure Ruby.
Diffstat (limited to 'textproc/ruby-xslt/Makefile')
-rw-r--r--textproc/ruby-xslt/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
new file mode 100644
index 000000000000..f953478976cd
--- /dev/null
+++ b/textproc/ruby-xslt/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-xmlscan
+# Date created: 22 August 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xslt
+PORTVERSION= 0.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.fantasy-coders.de/ruby/xslt4r/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}4r-${PORTVERSION:S/./_/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/xpathtree.rb:${PORTSDIR}/textproc/ruby-xmlscan
+
+USE_RUBY= yes
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/xslt.rb
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xslt.rb ${RUBY_SITELIBDIR}/
+ ${LN} -sf ${RUBY_SITELIBDIR}/xslt.rb ${LOCALBASE}/bin/xslt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/test/*.x* ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/ToDo ${RUBY_DOCDIR}/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>