aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/rubygem-ferret
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /textproc/rubygem-ferret
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'textproc/rubygem-ferret')
-rw-r--r--textproc/rubygem-ferret/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/textproc/rubygem-ferret/Makefile b/textproc/rubygem-ferret/Makefile
index 00e0a8c10701..83d9e80537e9 100644
--- a/textproc/rubygem-ferret/Makefile
+++ b/textproc/rubygem-ferret/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= RF
MAINTAINER= clsung@FreeBSD.org
COMMENT= Ferret is a ruby port of Lucene
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
-
USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} ! -type d | \
@@ -27,6 +27,4 @@ post-install:
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d | ${SORT} -r | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>