aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/s5
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-01 15:12:37 +0800
committermarino <marino@FreeBSD.org>2014-06-01 15:12:37 +0800
commitcca013a377d9a57b2f5271f1df61f6aa572ad54c (patch)
tree84c0bf0a2c79bc34c5292dbaf0f0bfbddd965247 /textproc/s5
parentf09ca5d90540c5406bf951c8f62b90115caacda5 (diff)
downloadfreebsd-ports-gnome-cca013a377d9a57b2f5271f1df61f6aa572ad54c.tar.gz
freebsd-ports-gnome-cca013a377d9a57b2f5271f1df61f6aa572ad54c.tar.zst
freebsd-ports-gnome-cca013a377d9a57b2f5271f1df61f6aa572ad54c.zip
textproc/s5: use TAR instead of EXTRACT_CMD
This actually changes the extract tool from /usr/bin/unzip to /usr/bin/tar because UNZIP_CMD currently refers to $LOCALBASE/bin/unzip so using that would require a new dependency on info. To avoid adding a new dependency, just use TAR which works fine.
Diffstat (limited to 'textproc/s5')
-rw-r--r--textproc/s5/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/textproc/s5/Makefile b/textproc/s5/Makefile
index 93f4870743d3..e6b5046cb8c6 100644
--- a/textproc/s5/Makefile
+++ b/textproc/s5/Makefile
@@ -22,7 +22,7 @@ S5_DIR= ${PREFIX}/share/${PORTNAME}
S5_SUBDIRS= pix primer s5-blank ui
post-extract:
- cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} s5-blank.zip ${EXTRACT_AFTER_ARGS}
+ cd ${WRKSRC} && ${TAR} -xf s5-blank.zip
${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5.sh > ${WRKDIR}/s5
${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5.1 > ${WRKDIR}/s5.1
${FIND} ${WRKDIR} -type f -name .DS_Store -delete