aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sablotron/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-12-13 01:55:18 +0800
committerskv <skv@FreeBSD.org>2004-12-13 01:55:18 +0800
commitcdb4ade74782c96ebb9c8ffe465213edc6174787 (patch)
treefe00e8d5793bf88ffc5af3dcbaf1d7a703c1065d /textproc/sablotron/Makefile
parentc346b776a5944839eee6775cb516c8bd9d7dac31 (diff)
downloadfreebsd-ports-gnome-cdb4ade74782c96ebb9c8ffe465213edc6174787.tar.gz
freebsd-ports-gnome-cdb4ade74782c96ebb9c8ffe465213edc6174787.tar.zst
freebsd-ports-gnome-cdb4ade74782c96ebb9c8ffe465213edc6174787.zip
* use OPTIONS
* unbreak build with -DWITH_CHECK_LEAKS [PR 72754] PR: ports/72754 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
Diffstat (limited to 'textproc/sablotron/Makefile')
-rw-r--r--textproc/sablotron/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/textproc/sablotron/Makefile b/textproc/sablotron/Makefile
index 98f19cdb4d38..9597f3baf39e 100644
--- a/textproc/sablotron/Makefile
+++ b/textproc/sablotron/Makefile
@@ -15,12 +15,12 @@ COMMENT= XML toolkit implementing XSLT 1.0, XPath 1.0 and DOM Level2
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
-# If WITH_DISABLE_META is defined sablot will not output the META html tag
-#WITH_DISABLE_META= yes
-
-# Define WITH_ICONV_TYPECAST to typecast the second parameter
-# of iconv to char**
-#WITH_ICONV_TYPECAST= yes
+OPTIONS= DISABLE_META "Do not output the META html tag" off \
+ ICONV_TYPECAST "Use iconv typecast" off \
+ DOM "Use DOM" on \
+ DOCUMENT_ERRORS "Allow document errors" on \
+ CHECK_LEAKS "Enable memory leaks checking" off \
+ DEBUGGER "Enable debugger" off
INSTALLS_SHLIB= yes
@@ -38,7 +38,7 @@ MAN1= sabcmd.1
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_ADDING_META)
+.if defined(WITH_DISABLE_META)
CONFIGURE_ARGS+= --disable-adding-meta
.endif
@@ -73,6 +73,7 @@ post-patch:
@${PERL} -pi -e \
's!(?<=libsablot_la_LDFLAGS = -version-info )(\d+):(\d+):\1!${SHLIB_MAJOR}:$$1:${SHLIB_MAJOR}!;' \
${WRKSRC}/src/engine/Makefile.in
+ @${PERL} -pi -e 's!se // !! if $$. = 407' ${WRKSRC}/src/engine/base.h
.if defined(NOPORTDOCS)
@${PERL} -pi -e 's!(?<=SUBDIRS = )(.*)!man!' ${WRKSRC}/doc/Makefile.in
.endif