aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/saxon-he
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-07-08 04:36:36 +0800
committerglewis <glewis@FreeBSD.org>2004-07-08 04:36:36 +0800
commit11837223ee15e49d34d53584cad3e4f0b9fb2b31 (patch)
tree370182f019e69f4cb52ba86794cffebead6211b7 /textproc/saxon-he
parent6d253a71e9c3e6c6a7e01208efd7aa55b3d1fcb7 (diff)
downloadfreebsd-ports-gnome-11837223ee15e49d34d53584cad3e4f0b9fb2b31.tar.gz
freebsd-ports-gnome-11837223ee15e49d34d53584cad3e4f0b9fb2b31.tar.zst
freebsd-ports-gnome-11837223ee15e49d34d53584cad3e4f0b9fb2b31.zip
. Add a saxon-devel port for the development version of Saxon:
"The Saxon 8.0 package is a collection of tools for processing XML documents. The main components are: - An XSLT 2.0 processor, that can be used from the command line, or invoked from a Java application by use of the standard JAXP API. Saxon can be integrated with Java applications using the JAXP API, which means it is possible for a Java application to switch between different XSLT processors without changing the application code. As well as conforming closely with the XSLT 2.0 specification, Saxon offers a number of powerful extensions. - An XPath 2.0 processor accessible via an API to Java applications. - An XQuery 1.0 processor that can be used from the command line, or invoked from a Java application by use of an API. - An XML Schema 1.0 processor. This can be used on its own to validate a schema for correctness, or to validate a source document against the definitions in a schema. It is also used to support the schema-aware functionality of the XSLT and XQuery processors. So you can use Saxon to process XML by writing XSLT stylesheets, by writing XQuery queries, by writing Java applications, or by combinations of the approaches." PR: 68637 Submitted by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
Diffstat (limited to 'textproc/saxon-he')
-rw-r--r--textproc/saxon-he/Makefile66
-rw-r--r--textproc/saxon-he/distinfo2
-rw-r--r--textproc/saxon-he/files/saxon.sh6
-rw-r--r--textproc/saxon-he/pkg-descr22
-rw-r--r--textproc/saxon-he/pkg-plist63
5 files changed, 159 insertions, 0 deletions
diff --git a/textproc/saxon-he/Makefile b/textproc/saxon-he/Makefile
new file mode 100644
index 000000000000..b7778e06b5d2
--- /dev/null
+++ b/textproc/saxon-he/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: saxon-devel
+# Date created: 03 July 2004
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= saxon
+PORTVERSION= 8.0
+CATEGORIES= textproc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= saxon
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}b${PORTVERSION:S/./-/g}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
+
+RUN_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+CONFLICTS= saxon-6.*
+
+JARFILES= saxon8-sql.jar saxon8-jdom.jar saxon8.jar
+PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,} bin/saxon
+.if !defined(NOPORTDOCS)
+PORTDOCS= background documentation img index.html javadoc saxon.css
+.endif
+
+do-configure:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g ; s|%%JAVAJARDIR%%|${JAVAJARDIR}|g' \
+ ${FILESDIR}/saxon.sh >${WRKSRC}/saxon
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JARs in ${JAVAJARDIR}..."
+ @${MKDIR} ${JAVAJARDIR}
+.for JARFILE in ${JARFILES}
+ @${ECHO_MSG} -n " ${JARFILE}"
+ @${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}/
+.endfor
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/samples/* ${EXAMPLESDIR}/
+ @${CHOWN} -h -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ @${ECHO_MSG} -n " ${DOCFILE}"
+ @${CP} -R ${WRKSRC}/doc/${DOCFILE} ${DOCSDIR}/
+.endfor
+ @${CHOWN} -h -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+ @${ECHO_MSG} -n ">> Installing script in ${PREFIX}/bin..."
+ @${INSTALL_SCRIPT} ${WRKSRC}/saxon ${PREFIX}/bin/
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/textproc/saxon-he/distinfo b/textproc/saxon-he/distinfo
new file mode 100644
index 000000000000..d7a867a34de2
--- /dev/null
+++ b/textproc/saxon-he/distinfo
@@ -0,0 +1,2 @@
+MD5 (saxonb8-0.zip) = d05fbd398847ef27b2d1d875bb5136ea
+SIZE (saxonb8-0.zip) = 5465208
diff --git a/textproc/saxon-he/files/saxon.sh b/textproc/saxon-he/files/saxon.sh
new file mode 100644
index 000000000000..63673bc9bdb3
--- /dev/null
+++ b/textproc/saxon-he/files/saxon.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-he/files/Attic/saxon.sh,v 1.1 2004-07-07 20:36:36 glewis Exp $
+
+export CLASSPATH=`%%PREFIX%%/bin/classpath`
+javavm -jar %%JAVAJARDIR%%/saxon8.jar $@
diff --git a/textproc/saxon-he/pkg-descr b/textproc/saxon-he/pkg-descr
new file mode 100644
index 000000000000..362261376106
--- /dev/null
+++ b/textproc/saxon-he/pkg-descr
@@ -0,0 +1,22 @@
+The Saxon 8.0 package is a collection of tools for processing XML documents.
+The main components are:
+
+- An XSLT 2.0 processor, that can be used from the command line, or invoked
+ from a Java application by use of the standard JAXP API. Saxon can be
+ integrated with Java applications using the JAXP API, which means it is
+ possible for a Java application to switch between different XSLT processors
+ without changing the application code. As well as conforming closely with the
+ XSLT 2.0 specification, Saxon offers a number of powerful extensions.
+- An XPath 2.0 processor accessible via an API to Java applications.
+- An XQuery 1.0 processor that can be used from the command line, or invoked
+ from a Java application by use of an API.
+- An XML Schema 1.0 processor. This can be used on its own to validate a schema
+ for correctness, or to validate a source document against the definitions in
+ a schema. It is also used to support the schema-aware functionality of the
+ XSLT and XQuery processors.
+
+So you can use Saxon to process XML by writing XSLT stylesheets, by writing
+XQuery queries, by writing Java applications, or by combinations of the
+approaches.
+
+WWW: http://saxon.sourceforge.net/
diff --git a/textproc/saxon-he/pkg-plist b/textproc/saxon-he/pkg-plist
new file mode 100644
index 000000000000..8af20892f6d2
--- /dev/null
+++ b/textproc/saxon-he/pkg-plist
@@ -0,0 +1,63 @@
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/text.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/preamble.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/multidoc.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/inc1/inc2/inc2.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/inc1/inc1.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/foo3.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/foo2.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/foo.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xsl/baz.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xml/subdir1/subdir2/foo3.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xml/subdir1/foo2.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xml/foo.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xml/embedded.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/xml/baz.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/trax/exampleSimple2.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/tour.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/total.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/play.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/identity.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/books.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/books-tle.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/books-sql.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/books-sa.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/books-csv.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles/bible.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/query/tour.xq
+%%PORTDOCS%%%%EXAMPLESDIR%%/query/books.xq
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/XPathExample.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/XPathExample.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples$UserURIResolver.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples$UserOutputResolver.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples$ModifyStylesheetFilter.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/TraxExamples$1.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/SaxonServlet.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/SaxonServlet.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/QuickValidator.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/QuickValidator.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/JDOMExample.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/JDOMExample.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/ExampleContentHandler.java
+%%PORTDOCS%%%%EXAMPLESDIR%%/java/ExampleContentHandler.class
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/tstmt.dtd
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/play.dtd
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/othello.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/books.xsd
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/books.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/data/books.dtd
+%%PORTDOCS%%%%EXAMPLESDIR%%/analysis/timing-profile.xsl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xsl/inc1/inc2
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xsl/inc1
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xsl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xml/subdir1/subdir2
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xml/subdir1
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax/xml
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/trax
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/styles
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/query
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/java
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/data
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/analysis
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/