aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/scim-openvanilla/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-01-20 18:08:11 +0800
committerclsung <clsung@FreeBSD.org>2006-01-20 18:08:11 +0800
commitbe8588f400bc28de01cf868a061cb7434e48b1bc (patch)
treeb6cef07e7e9bae96ae445186a6d792bf9950eaa9 /textproc/scim-openvanilla/Makefile
parent38a06447627b17639ba60db54b4b74279561a86f (diff)
downloadfreebsd-ports-gnome-be8588f400bc28de01cf868a061cb7434e48b1bc.tar.gz
freebsd-ports-gnome-be8588f400bc28de01cf868a061cb7434e48b1bc.tar.zst
freebsd-ports-gnome-be8588f400bc28de01cf868a061cb7434e48b1bc.zip
Add scim-openvanilla 0.7.1.20050902, SCIM OpenVanilla input method
(IM)/output filter (OF) framework. PR: ports/85731 Submitted by: Leland Wang <llwang@infor.org>
Diffstat (limited to 'textproc/scim-openvanilla/Makefile')
-rw-r--r--textproc/scim-openvanilla/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
new file mode 100644
index 000000000000..7087005e0e38
--- /dev/null
+++ b/textproc/scim-openvanilla/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: scim-openvanilla
+# Date Created: 3 September 2005
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-openvanilla
+PORTVERSION= 0.7.1.20050902
+CATEGORIES= textproc
+MASTER_SITES= http://www.csie.org/~llwang/ \
+ http://www.infor.org/~llwang/
+DISTNAME= openvanilla-${PORTVERSION}
+
+MAINTAINER= llwang@infor.org
+COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
+ ${X11BASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
+RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
+
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libltdl:15
+WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS=-I${X11BASE}/include \
+ OV_MODULEDIR=${PREFIX}/lib/openvanilla/
+
+.include <bsd.port.mk>