aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sgmls/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-09 10:51:56 +0800
committerwill <will@FreeBSD.org>2000-06-09 10:51:56 +0800
commit20ce90640deee64bd49e3a177493cc4a925f7ec2 (patch)
tree58d376a4be967ff27b5fa82dcb3e1e4de3507d12 /textproc/sgmls/Makefile
parent909c34543d4c37743baaa5b4dadd18fd54359a0e (diff)
downloadfreebsd-ports-gnome-20ce90640deee64bd49e3a177493cc4a925f7ec2.tar.gz
freebsd-ports-gnome-20ce90640deee64bd49e3a177493cc4a925f7ec2.tar.zst
freebsd-ports-gnome-20ce90640deee64bd49e3a177493cc4a925f7ec2.zip
Add sgmls, another SGML parser.
PR: 18973 Submitted by: justas <justas@mbank.lv>
Diffstat (limited to 'textproc/sgmls/Makefile')
-rw-r--r--textproc/sgmls/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/sgmls/Makefile b/textproc/sgmls/Makefile
new file mode 100644
index 000000000000..62494d190db2
--- /dev/null
+++ b/textproc/sgmls/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: sgmls
+# Date created: Jun 2, 2000
+# Whom: Eugene Furs <justas@mbank.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sgmls
+PORTVERSION= 1.1.91
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.jclark.com/pub/sgmls/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= justas@mbank.lv
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+HAS_CONFIGURE= yes
+INSTALL_TARGET= install install.man
+
+MAN1= sgmls.1 sgmlsasp.1 rast.1
+
+PROGS= sgmls sgmlsasp rast
+DOCS= ChangeLog INSTALL LICENSE NEWS README TODO
+
+post-build:
+.for file in ${PROGS}
+ @strip ${WRKSRC}/${file}
+.endfor
+ @cd ${WRKSRC} && ${MAKE} test
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @-${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for file in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
+
+.include <bsd.port.mk>