aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sowing/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-12-18 06:19:04 +0800
committerthierry <thierry@FreeBSD.org>2006-12-18 06:19:04 +0800
commite20ff1a4be41b2a3f558187e03dc9c87e7aafee4 (patch)
treebdaf0b35b1ea8ec87ed81aa1e16130e99913bae3 /textproc/sowing/Makefile
parentff4432700bf5a97c398475b4e10dad7c9ed3b8ab (diff)
downloadfreebsd-ports-gnome-e20ff1a4be41b2a3f558187e03dc9c87e7aafee4.tar.gz
freebsd-ports-gnome-e20ff1a4be41b2a3f558187e03dc9c87e7aafee4.tar.zst
freebsd-ports-gnome-e20ff1a4be41b2a3f558187e03dc9c87e7aafee4.zip
Finally import sowing, which is used by mpich2-1.0.5 to build its docs.
Diffstat (limited to 'textproc/sowing/Makefile')
-rw-r--r--textproc/sowing/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/sowing/Makefile b/textproc/sowing/Makefile
new file mode 100644
index 000000000000..d480809a95bb
--- /dev/null
+++ b/textproc/sowing/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: sowing
+# Date created: 27 September 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sowing
+PORTVERSION= 1.1.11
+CATEGORIES= textproc
+MASTER_SITES= ftp://info.mcs.anl.gov/pub/sowing/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Text processing tools to generate documentation from source files
+
+BUILD_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm \
+ latex:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+
+USE_PERL5= yes
+USE_GHOSTSCRIPT=yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
+CONFIGURE_ARGS= --datadir=${DATADIR}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+ALL_TARGET= all-redirect
+
+MAN1= bfort.1 doctext.1 tohtml.1
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} testing)
+.endif
+
+.include <bsd.port.mk>