aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sp/Makefile
diff options
context:
space:
mode:
authorchuckr <chuckr@FreeBSD.org>1999-06-03 05:39:10 +0800
committerchuckr <chuckr@FreeBSD.org>1999-06-03 05:39:10 +0800
commit081ad4eb082db65e60ce7cfd81892738b9bb4b44 (patch)
tree11c2a85a16f6f74b11195ee5e109e9a9c35a37af /textproc/sp/Makefile
parent4a92ee9414db75d5d5a1437d161b991b8ebbe98e (diff)
downloadfreebsd-ports-gnome-081ad4eb082db65e60ce7cfd81892738b9bb4b44.tar.gz
freebsd-ports-gnome-081ad4eb082db65e60ce7cfd81892738b9bb4b44.tar.zst
freebsd-ports-gnome-081ad4eb082db65e60ce7cfd81892738b9bb4b44.zip
Update sp port to 1.3. Changing the format a bit, too. John Fieber,
the old maintainer, agrees with it.
Diffstat (limited to 'textproc/sp/Makefile')
-rw-r--r--textproc/sp/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/textproc/sp/Makefile b/textproc/sp/Makefile
index c6d33343e35d..59f987b0b2c4 100644
--- a/textproc/sp/Makefile
+++ b/textproc/sp/Makefile
@@ -3,21 +3,25 @@
# Date created: April 26, 1997
# Whom: jfieber
#
-# $Id: Makefile,v 1.7 1998/10/14 23:30:12 jseger Exp $
+# $Id: Makefile,v 1.8 1998/10/16 02:55:50 jseger Exp $
#
-DISTNAME= sp-1.2.1
+DISTNAME= sp-1.3
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.jclark.com/pub/sp/
MAINTAINER= jfieber@FreeBSD.ORG
-# The shared libsp only works on post 2.1.x systems.
-# shared C++ libraries appear to be broken on post 2.2.1 system too...
-#.if exists(/usr/lib/libstdc++.a)
-#PLIST= ${PKGDIR}/PLIST-shared
-#post-install:
-# ${LDCONFIG} -m ${PREFIX}/lib
-#.endif
+post-patch:
+ $(CP) $(WRKSRC)/Makefile $(WRKSRC)/Makefile.sed
+ $(CP) $(WRKSRC)/Makefile.lib $(WRKSRC)/Makefile.lib.sed
+ $(SED) -e "s%/opt/local%$(PREFIX)%" <$(WRKSRC)/Makefile.sed >$(WRKSRC)/Makefile
+ $(SED) -e "s%/opt/local%$(PREFIX)%" <$(WRKSRC)/Makefile.lib.sed >$(WRKSRC)/Makefile.lib
+
+post-install:
+ $(MKDIR) $(PREFIX)/include/sp
+ $(MKDIR) $(PREFIX)/share/doc/sp
+ for file in $(WRKSRC)/include/*;do $(INSTALL_DATA) $$file $(PREFIX)/include/sp;done
+ for file in $(WRKSRC)/doc/*;do $(INSTALL_DATA) $$file $(PREFIX)/share/doc/sp;done
.include <bsd.port.mk>