aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sphinxsearch
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-07 16:42:42 +0800
committerpav <pav@FreeBSD.org>2009-12-07 16:42:42 +0800
commita20c138cac8415f225f57bf28f078b5c3df8a528 (patch)
tree3e886603b3737bb547a51aaf3b6ec5c4671d7c0b /textproc/sphinxsearch
parent1e2b4fac16358d8ad866c08a0c0ca9a77cbfb65b (diff)
downloadfreebsd-ports-gnome-a20c138cac8415f225f57bf28f078b5c3df8a528.tar.gz
freebsd-ports-gnome-a20c138cac8415f225f57bf28f078b5c3df8a528.tar.zst
freebsd-ports-gnome-a20c138cac8415f225f57bf28f078b5c3df8a528.zip
- Add unixODBC option
PR: ports/141231 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Diffstat (limited to 'textproc/sphinxsearch')
-rw-r--r--textproc/sphinxsearch/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index 70efc9932a19..85b62bdeb2ec 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -26,7 +26,8 @@ OPTIONS= MYSQL "MySQL support" on \
PGSQL "PostgreSQL support" off \
ICONV "Iconv support" on \
OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off \
- ID64 "use 64-bit document and word IDs" off
+ ID64 "use 64-bit document and word IDs" off \
+ UNIXODBC "unixODBC support" off
## FFR
## LIBSTEMMER "compile with libstemmer support" off
@@ -70,6 +71,13 @@ CXXFLAGS+= -O3 -fomit-frame-pointer
CONFIGURE_ARGS+= --enable-id64
.endif
+.if defined(WITH_UNIXODBC)
+CONFIGURE_ARGS+= --with-unixodbc
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.else
+CONFIGURE_ARGS+= --without-unixodbc
+.endif
+
## FFR. The snowball project doesn't release numbered versions of it's
## pre-processors. Instead, at arbitrary intervals a snapshot of their
## source repository is turned into a tarball (always the same filename)