aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/srilm/files
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-02-22 02:07:23 +0800
committerleeym <leeym@FreeBSD.org>2004-02-22 02:07:23 +0800
commit6cd422a9f831ec89b4d40c47ac155cf88a85407a (patch)
treefe2f6b784101b5ce0c528c59f2d12fb7bae3f15f /textproc/srilm/files
parentda7c6339e6dd304c26df8787ed364c455f5b215c (diff)
downloadfreebsd-ports-gnome-6cd422a9f831ec89b4d40c47ac155cf88a85407a.tar.gz
freebsd-ports-gnome-6cd422a9f831ec89b4d40c47ac155cf88a85407a.tar.zst
freebsd-ports-gnome-6cd422a9f831ec89b4d40c47ac155cf88a85407a.zip
SRILM is a toolkit for building and applying statistical language models (LMs),
primarily for use in speech recognition, statistical tagging and segmentation. It has been under development in the SRI Speech Technology and Research Laboratory since 1995. The toolkit has also greatly benefitted from its use and enhancements during the Johns Hopkins University/CLSP summer workshops in 1995, 1996, and 1997 SRILM consists of the following components: * A set of C++ class libraries implementing language models, supporting data stuctures and miscellaneous utility functions. * A set of executable programs built on top of these libraries to perform standard tasks such as training LMs and testing them on data, tagging or segmenting text, etc. * A collection of miscellaneous scripts facilitating minor related tasks. WWW: http://www.speech.sri.com/projects/srilm/ Author: stolcke@speech.sri.com PR: 60810 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Diffstat (limited to 'textproc/srilm/files')
-rw-r--r--textproc/srilm/files/patch-Makefile.common.variables11
-rw-r--r--textproc/srilm/files/patch-Makefile.machine.i38672
-rw-r--r--textproc/srilm/files/patch-bin-machine-type11
-rw-r--r--textproc/srilm/files/patch-go.run-test12
-rw-r--r--textproc/srilm/files/patch-lattice-src-Makefile11
-rw-r--r--textproc/srilm/files/patch-lm-src-Makefile11
6 files changed, 128 insertions, 0 deletions
diff --git a/textproc/srilm/files/patch-Makefile.common.variables b/textproc/srilm/files/patch-Makefile.common.variables
new file mode 100644
index 000000000000..4c90146bc4a5
--- /dev/null
+++ b/textproc/srilm/files/patch-Makefile.common.variables
@@ -0,0 +1,11 @@
+--- common/Makefile.common.variables.orig Sat Feb 22 06:43:31 2003
++++ common/Makefile.common.variables Thu Jan 1 02:57:25 2004
+@@ -52,7 +52,7 @@
+ DEMANGLE_FILTER = 2>&1 | c++filt
+
+ # Path to GNU awk; used in editing scripts
+-GAWK = /usr/local/bin/gawk
++GAWK = /usr/bin/awk
+
+ # Include machine-type dependent variables
+ include $(SRILM)/common/Makefile.machine.$(MACHINE_TYPE)
diff --git a/textproc/srilm/files/patch-Makefile.machine.i386 b/textproc/srilm/files/patch-Makefile.machine.i386
new file mode 100644
index 000000000000..5b30e33973c6
--- /dev/null
+++ b/textproc/srilm/files/patch-Makefile.machine.i386
@@ -0,0 +1,72 @@
+--- common/Makefile.machine.i386.orig Thu Jan 1 12:44:20 2004
++++ common/Makefile.machine.i386 Thu Jan 1 12:38:27 2004
+@@ -0,0 +1,69 @@
++#
++# File: Makefile.i686
++# Author: The SRI DECIPHER (TM) System
++# Date: Fri Feb 19 22:45:31 PST 1999
++#
++# Description:
++# Machine dependent compilation options and variable definitions
++# for Linux/i686 platform
++#
++# Copyright (c) 1999-2001 SRI International. All Rights Reserved.
++#
++# $Header: /home/srilm/devel/common/RCS/Makefile.machine.i686,v 1.8 2003/02/21 22:30:00 stolcke Exp $
++#
++
++ # Use the GNU C compiler.
++ GCC_FLAGS =
++ CC = gcc $(GCC_FLAGS)
++ CXX = g++ -Wno-deprecated $(GCC_FLAGS) -DINSTANTIATE_TEMPLATES
++
++ # Optional compilation flags.
++ OPTIMIZE_FLAGS = -g -O2
++ DEBUG_FLAGS = -g -DDEBUG
++ PROFILE_FLAGS = -g -pg -O2
++
++ # Optional linking flags.
++ EXPORT_LDFLAGS = -s
++
++ # Shared compilation flags.
++ CFLAGS = $(ADDITIONAL_CFLAGS) $(INCLUDES)
++ CXXFLAGS = $(ADDITIONAL_CXXFLAGS) $(INCLUDES)
++
++ # Shared linking flags.
++ LDFLAGS = $(ADDITIONAL_LDFLAGS) -L$(SRILM_LIBDIR)
++
++ # Other useful compilation flags.
++ ADDITIONAL_CFLAGS =
++ ADDITIONAL_CXXFLAGS =
++
++ # Other useful include directories.
++ ADDITIONAL_INCLUDES =
++
++ # Other useful linking flags.
++ ADDITIONAL_LDFLAGS =
++
++ # Other useful libraries.
++ ADDITIONAL_LIBRARIES = -L/home/clsung/srilm/work/srilm/dstruct/obj/i686 -L/home/clsung/srilm/work/srilm/misc/obj/i686 -L/home/clsung/srilm/work/srilm/htk/obj/i686 -L/home/clsung/srilm/work/srilm/lattice/obj/i686 -L/home/clsung/srilm/work/srilm/utils/obj/i686 -L/home/clsung/srilm/work/srilm/lm/obj/i686 -lm
++
++ # run-time linker path flag
++ RLD_FLAG = -R
++
++ # Tcl support (standard in Linux)
++ TCL_INCLUDE = -I/usr/local/include/tcl8.3
++ TCL_LIBRARY = -L/usr/local/lib -ltcl83
++
++ # No ranlib
++ RANLIB = :
++
++ # Generate dependencies from source files.
++ GEN_DEP = $(CC) $(CFLAGS) -MM
++
++ GEN_DEP.cc = $(CXX) $(CXXFLAGS) -MM
++
++ # Run lint.
++ LINT = lint
++ LINT_FLAGS = -DDEBUG $(CFLAGS)
++
++ # Location of awk binary
++ GAWK = /usr/bin/awk
++
diff --git a/textproc/srilm/files/patch-bin-machine-type b/textproc/srilm/files/patch-bin-machine-type
new file mode 100644
index 000000000000..a5d1f37f33b4
--- /dev/null
+++ b/textproc/srilm/files/patch-bin-machine-type
@@ -0,0 +1,11 @@
+--- bin/machine-type.orig Sat Feb 22 06:04:46 2003
++++ bin/machine-type Thu Jan 1 12:43:08 2004
+@@ -92,6 +92,8 @@
+ set MACHINE_TYPE = macosx
+ else if (`uname -m` == i686) then
+ set MACHINE_TYPE = i686
++ else if (`uname -m` == i386) then
++ set MACHINE_TYPE = i386
+ else
+ ## Generate an error by doing nothing. (Used to be the line below:)
+ ## echo "ERROR: Unsupported machine type: "$RESULT
diff --git a/textproc/srilm/files/patch-go.run-test b/textproc/srilm/files/patch-go.run-test
new file mode 100644
index 000000000000..96800a46af32
--- /dev/null
+++ b/textproc/srilm/files/patch-go.run-test
@@ -0,0 +1,12 @@
+--- test/go.run-test.orig Thu Jan 1 12:15:21 2004
++++ test/go.run-test Thu Jan 1 12:16:10 2004
+@@ -6,6 +6,9 @@
+ # $Header: /home/srilm/devel/test/RCS/go.run-test,v 1.10 2003/02/27 23:42:35 stolcke Exp $
+ #
+
++PATH=$PATH:$WRKSRC/bin:$WRKSRC/bin/i386
++export PATH
++
+ dir=$1
+
+ if [ -z "$MACHINE_TYPE" ]; then
diff --git a/textproc/srilm/files/patch-lattice-src-Makefile b/textproc/srilm/files/patch-lattice-src-Makefile
new file mode 100644
index 000000000000..3d538ac7eab6
--- /dev/null
+++ b/textproc/srilm/files/patch-lattice-src-Makefile
@@ -0,0 +1,11 @@
+--- lattice/src/Makefile.orig Sun Aug 25 05:29:45 2002
++++ lattice/src/Makefile Thu Jan 1 11:12:00 2004
+@@ -131,7 +131,7 @@
+ $(ARCHIVE) $@ $^ $(DEMANGLE_FILTER)
+ $(RANLIB) $@ $(DEMANGLE_FILTER)
+
+-$(PROGRAMS): $(LIBRARY) $(OTHER_LIBRARIES)
++$(PROGRAMS): $(LIBRARY)
+
+ # Variables and Targets for released system
+
diff --git a/textproc/srilm/files/patch-lm-src-Makefile b/textproc/srilm/files/patch-lm-src-Makefile
new file mode 100644
index 000000000000..ea48aee14621
--- /dev/null
+++ b/textproc/srilm/files/patch-lm-src-Makefile
@@ -0,0 +1,11 @@
+--- lm/src/Makefile.orig Sat Feb 22 04:20:46 2003
++++ lm/src/Makefile Thu Jan 1 11:11:40 2004
+@@ -234,7 +234,7 @@
+ $(ARCHIVE) $@ $^ $(DEMANGLE_FILTER)
+ $(RANLIB) $@ $(DEMANGLE_FILTER)
+
+-$(PROGRAMS): $(LIBRARY) $(OTHER_LIBRARIES)
++$(PROGRAMS): $(LIBRARY)
+
+ # Variables and Targets for released system
+