aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ssddiff/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-26 00:46:40 +0800
committermiwi <miwi@FreeBSD.org>2014-01-26 00:46:40 +0800
commitd4b27ea86f2be24f7cb0b6957592181c86aba9e0 (patch)
treec7a32f9b55c3775bb028258ccff08d2879e1a703 /textproc/ssddiff/Makefile
parentb66c3cdefa5efbdc67cb7193b46dcb9b8740913f (diff)
downloadfreebsd-ports-gnome-d4b27ea86f2be24f7cb0b6957592181c86aba9e0.tar.gz
freebsd-ports-gnome-d4b27ea86f2be24f7cb0b6957592181c86aba9e0.tar.zst
freebsd-ports-gnome-d4b27ea86f2be24f7cb0b6957592181c86aba9e0.zip
- Fix build
PR: 184870 Submitted by: Ports Fury
Diffstat (limited to 'textproc/ssddiff/Makefile')
-rw-r--r--textproc/ssddiff/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
index e70eeb837fac..2c8db5620eb8 100644
--- a/textproc/ssddiff/Makefile
+++ b/textproc/ssddiff/Makefile
@@ -8,23 +8,28 @@ CATEGORIES= textproc
MASTER_SITES= http://alioth.debian.org/frs/download.php/1469/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A diff application for semistructured data such as XML files
+COMMENT= Diff application for semistructured data such as XML files
+
+LICENSE= GPLv2 # (or later)
-USE_AUTOTOOLS= automake14
USE_BZIP2= yes
USES= pkgconfig
-USE_GNOME= libxml2
-MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include \
- -I${LOCALBASE}/include/libxml2"
+USE_GNOME= libxml2
+USE_GCC= any
+USE_AUTOTOOLS= automake14
+
PLIST_FILES= bin/xmldiff
-NO_STAGE= yes
post-extract:
+ @${FIND} ${WRKSRC} -type l -delete
+
+post-patch:
.for f in config.guess config.sub install-sh missing mkinstalldirs
@${LN} -sf ${AUTOMAKE_DIR}/${f} ${WRKSRC}/${f}
.endfor
- @${REINPLACE_CMD} -e 's,"getopt\.h",<unistd.h>,' \
- ${WRKSRC}/src/main.cc
+ @${REINPLACE_CMD} -e \
+ 's|^CXXFLAGS|AM_CPPFLAGS|' ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} -e \
+ 's|"getopt\.h"|<unistd.h>|' ${WRKSRC}/src/main.cc
.include <bsd.port.mk>