aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ssddiff/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-04-11 12:05:13 +0800
committerdanfe <danfe@FreeBSD.org>2006-04-11 12:05:13 +0800
commitaa4b580ce694e9eb7fb93595842a94171f62c0f3 (patch)
tree365795ffae44121d3f525f82710ff230c38754f5 /textproc/ssddiff/Makefile
parentbb752d917e52b2862fad24ae2de85365093e4377 (diff)
downloadfreebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.tar.gz
freebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.tar.zst
freebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.zip
Add ssddiff, a diff application for semistructured data such as XML files.
WWW: http://ssddiff.alioth.debian.org/
Diffstat (limited to 'textproc/ssddiff/Makefile')
-rw-r--r--textproc/ssddiff/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
new file mode 100644
index 000000000000..1fea2b072b48
--- /dev/null
+++ b/textproc/ssddiff/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: SSDDiff
+# Date created: 11 Apr 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssddiff
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://alioth.debian.org/download.php/1469/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A diff application for semistructured data such as XML files
+
+USE_AUTOTOOLS= automake:14
+USE_BZIP2= yes
+USE_GCC= 3.4+
+USE_GNOME= libxml2
+MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/libxml2"
+PLIST_FILES= bin/xmldiff
+
+post-extract:
+.for f in config.guess config.sub install-sh missing mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake14/${f} ${WRKSRC}/${f}
+.endfor
+
+.include <bsd.port.mk>