aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ssddiff
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-04-11 12:05:13 +0800
committerdanfe <danfe@FreeBSD.org>2006-04-11 12:05:13 +0800
commitaa4b580ce694e9eb7fb93595842a94171f62c0f3 (patch)
tree365795ffae44121d3f525f82710ff230c38754f5 /textproc/ssddiff
parentbb752d917e52b2862fad24ae2de85365093e4377 (diff)
downloadfreebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.tar.gz
freebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.tar.zst
freebsd-ports-gnome-aa4b580ce694e9eb7fb93595842a94171f62c0f3.zip
Add ssddiff, a diff application for semistructured data such as XML files.
WWW: http://ssddiff.alioth.debian.org/
Diffstat (limited to 'textproc/ssddiff')
-rw-r--r--textproc/ssddiff/Makefile30
-rw-r--r--textproc/ssddiff/distinfo3
-rw-r--r--textproc/ssddiff/pkg-descr15
3 files changed, 48 insertions, 0 deletions
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
new file mode 100644
index 000000000000..1fea2b072b48
--- /dev/null
+++ b/textproc/ssddiff/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: SSDDiff
+# Date created: 11 Apr 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssddiff
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://alioth.debian.org/download.php/1469/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A diff application for semistructured data such as XML files
+
+USE_AUTOTOOLS= automake:14
+USE_BZIP2= yes
+USE_GCC= 3.4+
+USE_GNOME= libxml2
+MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/libxml2"
+PLIST_FILES= bin/xmldiff
+
+post-extract:
+.for f in config.guess config.sub install-sh missing mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake14/${f} ${WRKSRC}/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/ssddiff/distinfo b/textproc/ssddiff/distinfo
new file mode 100644
index 000000000000..db8fcfeee2af
--- /dev/null
+++ b/textproc/ssddiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (ssddiff-0.2.tar.bz2) = 3d34d14121715c23c04a9d1953bd4d44
+SHA256 (ssddiff-0.2.tar.bz2) = 2c0c3fe73d149f92b74005805c5b5135a47d88eea83493255c31ab931281b9be
+SIZE (ssddiff-0.2.tar.bz2) = 86679
diff --git a/textproc/ssddiff/pkg-descr b/textproc/ssddiff/pkg-descr
new file mode 100644
index 000000000000..b45fe365b057
--- /dev/null
+++ b/textproc/ssddiff/pkg-descr
@@ -0,0 +1,15 @@
+Semistructured data is a generic term for data that does have structure
+information, while not being tabular or very tightly restricted. XML and
+HTML data is the most prominent examples for this. You normally would not
+use this term e.g. for database tables (which for example do not allow
+nesting of entries).
+
+While this application currently only supports XML, the algorithms should be
+able to process other semistructured data as well.
+
+The approach used here is usually much slower than other well-known xmldiff
+applications, however it produces better results in many "tricky" cases.
+You say that other xmldiff applications try to do a syntactic diff, whereas
+xmldiff tries to do a semantic diff.
+
+WWW: http://ssddiff.alioth.debian.org/