aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/svn2cl
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-22 03:33:41 +0800
committermiwi <miwi@FreeBSD.org>2006-12-22 03:33:41 +0800
commit600685210cb028619adda0de42949dfb7abff898 (patch)
tree35ef4e585deac15049e62ab0d3f1a2667a509f10 /textproc/svn2cl
parentb1b4ffe68c37936aaa261c1788d51b25a903433d (diff)
downloadfreebsd-ports-gnome-600685210cb028619adda0de42949dfb7abff898.tar.gz
freebsd-ports-gnome-600685210cb028619adda0de42949dfb7abff898.tar.zst
freebsd-ports-gnome-600685210cb028619adda0de42949dfb7abff898.zip
svn2cl is a simple xsl transformation and shell script wrapper for generating
a classic GNU-style ChangeLog from a subversion repository log. It is made from several changelog-like scripts using common xslt constructs found in different places. WWW: http://ch.tudelft.nl/~arthur/svn2cl/ PR: ports/107007 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'textproc/svn2cl')
-rw-r--r--textproc/svn2cl/Makefile41
-rw-r--r--textproc/svn2cl/distinfo3
-rw-r--r--textproc/svn2cl/pkg-descr6
-rw-r--r--textproc/svn2cl/pkg-plist6
4 files changed, 56 insertions, 0 deletions
diff --git a/textproc/svn2cl/Makefile b/textproc/svn2cl/Makefile
new file mode 100644
index 000000000000..7e88deb12779
--- /dev/null
+++ b/textproc/svn2cl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: svn2cl
+# Date created: 20 December 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= svn2cl
+PORTVERSION= 0.8
+CATEGORIES= textproc
+MASTER_SITES= http://ch.tudelft.nl/~arthur/svn2cl/
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Subversion ChangeLog generator
+
+RUN_DEPENDS= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion
+
+NO_BUILD= yes
+MAN1= ${PORTNAME}.1
+PORTDOCS= ChangeLog NEWS README TODO
+DATAFILES= authors.xml svn2cl.xsl svn2cl.xsl svn2html.css svn2html.xsl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|XSL="$$dir|XSL="${DATADIR}|' ${WRKSRC}/${PORTNAME}.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+.for i in ${DATAFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/svn2cl/distinfo b/textproc/svn2cl/distinfo
new file mode 100644
index 000000000000..2a4ef7913733
--- /dev/null
+++ b/textproc/svn2cl/distinfo
@@ -0,0 +1,3 @@
+MD5 (svn2cl-0.8.tar.gz) = 240cb722c31823cd37c39361efbc37f1
+SHA256 (svn2cl-0.8.tar.gz) = 46bc4998c5ce54da86771c0f7b027c1e877f5dc5a5fb7a30fcbbfe0eb244fdc8
+SIZE (svn2cl-0.8.tar.gz) = 16820
diff --git a/textproc/svn2cl/pkg-descr b/textproc/svn2cl/pkg-descr
new file mode 100644
index 000000000000..6ee3028b4efe
--- /dev/null
+++ b/textproc/svn2cl/pkg-descr
@@ -0,0 +1,6 @@
+svn2cl is a simple xsl transformation and shell script wrapper for generating
+a classic GNU-style ChangeLog from a subversion repository log. It is made
+from several changelog-like scripts using common xslt constructs found in
+different places.
+
+WWW: http://ch.tudelft.nl/~arthur/svn2cl/
diff --git a/textproc/svn2cl/pkg-plist b/textproc/svn2cl/pkg-plist
new file mode 100644
index 000000000000..e924c6ce8a77
--- /dev/null
+++ b/textproc/svn2cl/pkg-plist
@@ -0,0 +1,6 @@
+bin/svn2cl
+%%DATADIR%%/authors.xml
+%%DATADIR%%/svn2cl.xsl
+%%DATADIR%%/svn2html.css
+%%DATADIR%%/svn2html.xsl
+@dirrmtry share/svn2cl