aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/te-hunspell
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
commite7533864e7a7574c2d1b20a6b10f81c0561e4621 (patch)
tree709c0318625f1fe2eca8e12b791e969926c96e91 /textproc/te-hunspell
parent3bc9ecccbd8279e4254d8eade21cc1a1837decfb (diff)
downloadfreebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.gz
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.zst
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Diffstat (limited to 'textproc/te-hunspell')
-rw-r--r--textproc/te-hunspell/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/textproc/te-hunspell/Makefile b/textproc/te-hunspell/Makefile
index d13c9855af03..eb7d9796a2b0 100644
--- a/textproc/te-hunspell/Makefile
+++ b/textproc/te-hunspell/Makefile
@@ -5,32 +5,33 @@
# $FreeBSD$
#
-PORTNAME= te-hunspell
+PORTNAME= hunspell
DISTVERSION= 0.01-2
+PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.gnu.org/gnu/aspell/dict/te/
+MASTER_SITES= GNU/aspell/dict/te
+PKGNAMEPREFIX= te-
DISTNAME= aspell6-te-${DISTVERSION}
MAINTAINER= office@FreeBSD.org
COMMENT= Telugu hunspell dictionaries
-BUILD_DEPENDS= wordlist2hunspell:${PORTSDIR}/textproc/hunspell \
- prezip-bin:${PORTSDIR}/textproc/aspell
-USE_BZIP2= yes
+BUILD_DEPENDS= prezip-bin:${PORTSDIR}/textproc/aspell \
+ wordlist2hunspell:${PORTSDIR}/textproc/hunspell
-PLIST_FILES= share/hunspell/te_IN.aff \
- share/hunspell/te_IN.dic
+USE_BZIP2= yes
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/te_IN.aff \
+ %%DATADIR%%/te_IN.dic
+PLIST_DIRSTRY= %%DATADIR%%
do-build:
@cd ${WRKSRC}; \
- ${LOCALBASE}/bin/prezip-bin -d < te.cwl > te.txt; \
- LANG=te_IN.utf8 ${LOCALBASE}/bin/wordlist2hunspell te.txt te_IN
+ ${LOCALBASE}/bin/prezip-bin -d < te.cwl > te.txt; \
+ ${SETENV} LANG=te_IN.utf8 ${LOCALBASE}/bin/wordlist2hunspell te.txt te_IN
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKSRC}/te_IN.aff ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKSRC}/te_IN.dic ${PREFIX}/share/hunspell
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/te_IN.aff ${WRKSRC}/te_IN.dic ${DATADIR}/
.include <bsd.port.mk>