aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/tkxmlive/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 15:43:11 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 15:43:11 +0800
commit387ae91e764f59b0e149f58b2853fc70a54ce542 (patch)
treea69a43703f039e81a8cc3b49dcf8151738ce87e5 /textproc/tkxmlive/Makefile
parent456fb53ad93fc289d0fc758dd36d49bb8f59c310 (diff)
downloadfreebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.tar.gz
freebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.tar.zst
freebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.zip
[NEW PORT] textproc/tkxmlive - Tcl/Tk XML Intelligence Visual Editor
Tcl/TK XML Intelligence Visual Editor WWW: http://tkxmlive.sourceforge.netTcl/ PR: ports/70846 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'textproc/tkxmlive/Makefile')
-rw-r--r--textproc/tkxmlive/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/textproc/tkxmlive/Makefile b/textproc/tkxmlive/Makefile
new file mode 100644
index 000000000000..44fe3a202df7
--- /dev/null
+++ b/textproc/tkxmlive/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: tkxmlive
+# Date created: 4 December 2003
+# Whom: nivit@users.sourceforge.net
+#
+# $FreeBSD$
+
+PORTNAME= tkxmlive
+PORTVERSION= 0.1.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= tkxmlive-0.1.5-1
+
+MAINTAINER= nivit@users.sourceforge.net
+COMMENT= Tcl/Tk XML Intelligence Visual Editor
+
+RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ ${LOCALBASE}/lib/bwidget/pkgIndex.tcl:${PORTSDIR}/x11-toolkits/bwidget
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+TK_VER?= 8.4
+WISH= wish${TK_VER}
+
+REPLACE_FILES= ${WRKSRC}/interface.tcl \
+ ${WRKSRC}/tkxmlive
+
+post-patch: .SILENT
+ for FILE in ${REPLACE_FILES}; do \
+ ${SED} -i .bak\
+ -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" \
+ -e "/%%PREFIX%%/s//${PREFIX:S/\//\\\//g}/g" \
+ -e "/%%WISH%%/s//${WISH:S/\//\\\//g}/g" \
+ $${FILE}; \
+ done;
+
+LN_OPTS?= -sf
+
+FIND_ARGS1= -type d \! -empty
+FIND_ARGS2= -type f -and -perm -a+x -and \! \
+ -name "*.orig" \! -name "*.bak"
+FIND_ARGS3= -type f -and \! -perm -a+x -and \! \
+ -name "*.orig" \! -name "*~" \! \
+ -regex ".*[[:upper:]]+"
+
+do-install: .SILENT
+# Script and data
+ cd ${WRKSRC}; \
+ DIRS=$$(${FIND} . ${FIND_ARGS1}); \
+ for DIR in $${DIRS}; do \
+ ${MKDIR} ${DATADIR}/$${DIR}; \
+ done; \
+ FILES=$$(${FIND} . ${FIND_ARGS2}); \
+ for FILE in $${FILES}; do \
+ ${INSTALL_SCRIPT} $${FILE} ${DATADIR}/$${FILE}; \
+ done; \
+ FILES=$$(${FIND} -E . ${FIND_ARGS3}); \
+ for FILE in $${FILES}; do \
+ ${INSTALL_DATA} $${FILE} ${DATADIR}/$${FILE}; \
+ done;
+
+# Links to executables
+ cd ${WRKSRC}; \
+ FILES=${PORTNAME}; \
+ for f in $${FILES}; do \
+ ${LN} ${LN_OPTS} ${DATADIR}/$${f} ${PREFIX}/bin/$${f}; \
+ done;
+
+.include <bsd.port.post.mk>