aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim-kde4
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2010-11-27 01:38:22 +0800
committernobutaka <nobutaka@FreeBSD.org>2010-11-27 01:38:22 +0800
commitf0e7020378256f485f421bc0cfbe77777f390ace (patch)
tree992cda0793e1d55f3b2c5a045dacc69128a49a9a /textproc/uim-kde4
parentdbf0884f490bd6da081c712061344d5472e64706 (diff)
downloadfreebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.tar.gz
freebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.tar.zst
freebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.zip
- Update to 1.6.0.
- Add textproc/uim-kde4, KDE4 panel applet of uim input method. It is a slave port of textproc/uim. - Remove japanese/uim-canna and japanese/uim-prime. Now the canna and prime modules are implemented as scheme scripts and they can be installed from textproc/uim. - Enable helper tools installation of textproc/uim-qt4. - Enable sj3 support of textproc/uim.
Diffstat (limited to 'textproc/uim-kde4')
-rw-r--r--textproc/uim-kde4/Makefile40
-rw-r--r--textproc/uim-kde4/pkg-descr3
-rw-r--r--textproc/uim-kde4/pkg-plist2
3 files changed, 45 insertions, 0 deletions
diff --git a/textproc/uim-kde4/Makefile b/textproc/uim-kde4/Makefile
new file mode 100644
index 000000000000..14a009b50d4e
--- /dev/null
+++ b/textproc/uim-kde4/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: uim-kde4
+# Date created: 26 November 2010
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -kde4
+
+COMMENT= KDE4 panel applet of uim input method
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+LIB_DEPENDS= uim.7:${PORTSDIR}/textproc/uim
+RUN_DEPENDS= uim-pref-qt4:${PORTSDIR}/textproc/uim-qt
+
+USE_GCC= 4.2+
+USE_KDE4= kdelibs automoc4
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build qt3support uic rcc
+USE_AUTOTOOLS= libtool:22
+
+MASTERDIR= ${.CURDIR}/../../textproc/uim
+PKGDIR= ${.CURDIR}
+CONFIGURE_ARGS= --with-qt4 --enable-pref --enable-default-toolkit=qt4 \
+ --enable-kde4-applet
+UIM_SLAVE= yes
+
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt4_toolbar_CMakeLists.txt
+
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
+do-build:
+ (cd ${WRKSRC}/qt4/toolbar/build && ${SETENV} ${MAKE_ENV} ${GMAKE})
+
+do-install:
+ (cd ${WRKSRC}/qt4/toolbar/build && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/uim-kde4/pkg-descr b/textproc/uim-kde4/pkg-descr
new file mode 100644
index 000000000000..4a39d31b3738
--- /dev/null
+++ b/textproc/uim-kde4/pkg-descr
@@ -0,0 +1,3 @@
+KDE4 panel applet of uim input method.
+
+WWW: http://code.google.com/p/uim/
diff --git a/textproc/uim-kde4/pkg-plist b/textproc/uim-kde4/pkg-plist
new file mode 100644
index 000000000000..52a8f47a337d
--- /dev/null
+++ b/textproc/uim-kde4/pkg-plist
@@ -0,0 +1,2 @@
+kde4/lib/kde4/plasma_applet_uim.so
+kde4/share/kde4/services/plasma-applet-uim.desktop