aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim-kde
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2007-10-14 23:12:51 +0800
committernobutaka <nobutaka@FreeBSD.org>2007-10-14 23:12:51 +0800
commitf01e2eb71d0d1e47b39056613e1065d21878410a (patch)
treedc4150b76d1c39f991128c457c5981444eab7a8a /textproc/uim-kde
parent3d71eebae220bd32b9f5271dfe8b2d53639f00db (diff)
downloadfreebsd-ports-gnome-f01e2eb71d0d1e47b39056613e1065d21878410a.tar.gz
freebsd-ports-gnome-f01e2eb71d0d1e47b39056613e1065d21878410a.tar.zst
freebsd-ports-gnome-f01e2eb71d0d1e47b39056613e1065d21878410a.zip
- Update to 1.4.1.
- Update WWW entry in pkg-descr.
Diffstat (limited to 'textproc/uim-kde')
-rw-r--r--textproc/uim-kde/Makefile20
-rw-r--r--textproc/uim-kde/pkg-descr2
2 files changed, 7 insertions, 15 deletions
diff --git a/textproc/uim-kde/Makefile b/textproc/uim-kde/Makefile
index 35ddaae1b792..838e8809db38 100644
--- a/textproc/uim-kde/Makefile
+++ b/textproc/uim-kde/Makefile
@@ -9,17 +9,17 @@ PKGNAMESUFFIX= -kde
COMMENT= KDE panel applet of uim input method
-LIB_DEPENDS= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33 \
- uim.4:${PORTSDIR}/textproc/uim
-RUN_DEPENDS= uim-pref-qt:${PORTSDIR}/textproc/uim-qt
-
USE_KDELIBS_VER=3
+USE_QT_VER= 3
USE_AUTOTOOLS= libtool:15
+LIB_DEPENDS= uim.5:${PORTSDIR}/textproc/uim
+RUN_DEPENDS= uim-pref-qt:${PORTSDIR}/textproc/uim-qt
+
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt --enable-pref --enable-default-toolkit=qt \
- --enable-kde-applet=yes
+ --enable-kde-applet
CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
CXX="${CXX} -lc" \
@@ -28,14 +28,6 @@ CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib"
UIM_SLAVE= yes
-# This is normally handled by defining USE_QT_VER ...
-
-.if defined(PACKAGE_BUILDING)
-TMPDIR?= /tmp
-MAKE_ENV+= TMPDIR="${TMPDIR}"
-CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
-.endif
-
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in
.if defined(WITHOUT_X11)
@@ -43,7 +35,7 @@ IGNORE= requires X11
.endif
do-build:
- (cd ${WRKSRC}/qt && ${GMAKE} LIBTOOL=${WRKSRC}/libtool LIBS="-luim -luim-custom" uim_panelapplet.la)
+ (cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} LIBTOOL=${WRKSRC}/libtool LIBS="-luim -luim-custom" uim_panelapplet.la)
do-install:
(cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} install-appletLTLIBRARIES install-lnkDATA)
diff --git a/textproc/uim-kde/pkg-descr b/textproc/uim-kde/pkg-descr
index c92c3c50cda3..f07872eb5055 100644
--- a/textproc/uim-kde/pkg-descr
+++ b/textproc/uim-kde/pkg-descr
@@ -1,3 +1,3 @@
KDE panel applet of uim input method.
-WWW: http://uim.freedesktop.org/wiki/
+WWW: http://code.google.com/p/uim/