aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim-qt
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2010-11-27 01:38:22 +0800
committernobutaka <nobutaka@FreeBSD.org>2010-11-27 01:38:22 +0800
commitf0e7020378256f485f421bc0cfbe77777f390ace (patch)
tree992cda0793e1d55f3b2c5a045dacc69128a49a9a /textproc/uim-qt
parentdbf0884f490bd6da081c712061344d5472e64706 (diff)
downloadfreebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.tar.gz
freebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.tar.zst
freebsd-ports-gnome-f0e7020378256f485f421bc0cfbe77777f390ace.zip
- Update to 1.6.0.
- Add textproc/uim-kde4, KDE4 panel applet of uim input method. It is a slave port of textproc/uim. - Remove japanese/uim-canna and japanese/uim-prime. Now the canna and prime modules are implemented as scheme scripts and they can be installed from textproc/uim. - Enable helper tools installation of textproc/uim-qt4. - Enable sj3 support of textproc/uim.
Diffstat (limited to 'textproc/uim-qt')
-rw-r--r--textproc/uim-qt/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index 15a7a4d01467..134c3e99b5f6 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -12,17 +12,17 @@ COMMENT= QT modules of uim input method
USE_QT_VER= 3
USE_AUTOTOOLS= libtool:22
-LIB_DEPENDS= uim.6:${PORTSDIR}/textproc/uim
+LIB_DEPENDS= uim.7:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt --enable-pref --enable-default-toolkit=qt \
--disable-kde-applet
-CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
- CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
- CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ENV= QTDIR=${LOCALBASE}/lib QTINCDIR=${LOCALBASE}/include \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${LIBS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in \