aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uncrustify/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-07-22 17:23:56 +0800
committermiwi <miwi@FreeBSD.org>2006-07-22 17:23:56 +0800
commitbb62654c2c2ec0278898f029e5e3c28c7e16a0cb (patch)
treede0e827094fec201ebf60755e02f20347fd0828f /textproc/uncrustify/Makefile
parenta1dd54cbe211506b96d323b6cd37b30d193b627a (diff)
downloadfreebsd-ports-gnome-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.tar.gz
freebsd-ports-gnome-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.tar.zst
freebsd-ports-gnome-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.zip
Add uncrustify , highly configurable source code beautifier.
The goals of this project are simple: Create a highly configurable, easily modifiable source code beautifier. What it does: * Ident code, aligning on parens, assignments, etc * Align on '=' and variable definitions * Align structure initializers * Align #define stuff * Align backslash-newline stuff * Reformat comments (a little bit) * Fix inter-character spacing * Add or remove parens on return statements * Add or remove braces on single-statement if/do/while/for statements * Highly configurable - 118 configurable options as of version 0.0.15 WWW: http://uncrustify.sourceforge.net PR: ports/100604 Submitted by: Dmitry Marakasov <amdmi3 at mail.ru>
Diffstat (limited to 'textproc/uncrustify/Makefile')
-rw-r--r--textproc/uncrustify/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/textproc/uncrustify/Makefile b/textproc/uncrustify/Makefile
new file mode 100644
index 000000000000..3f13e6c524a1
--- /dev/null
+++ b/textproc/uncrustify/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: uncrustify
+# Date created: 03 Jul 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uncrustify
+PORTVERSION= 0.0.22
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Highly configurable source code beautifier
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>