aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/unoconv
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-09-20 22:22:09 +0800
committerpawel <pawel@FreeBSD.org>2012-09-20 22:22:09 +0800
commitde49a99949a3c717805edce2894ffb1c5aa5d47e (patch)
treee732be067b099291e5cca0bcea59363cd45bd25d /textproc/unoconv
parentb1f0acf9f0709b752a7d168399aa98a8acf2e901 (diff)
downloadfreebsd-ports-gnome-de49a99949a3c717805edce2894ffb1c5aa5d47e.tar.gz
freebsd-ports-gnome-de49a99949a3c717805edce2894ffb1c5aa5d47e.tar.zst
freebsd-ports-gnome-de49a99949a3c717805edce2894ffb1c5aa5d47e.zip
Universal Office Converter (unoconv) is a command line tool to convert any
document format that LibreOffice can import to any document format that LibreOffice can export. It makes use of the LibreOffice's UNO bindings for non-interactive conversion of documents. For practical reasons we mention LibreOffice, but OpenOffice is supported by unoconv as well. WWW: http://dag.wieers.com/home-made/unoconv/ PR: ports/171789 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'textproc/unoconv')
-rw-r--r--textproc/unoconv/Makefile65
-rw-r--r--textproc/unoconv/distinfo2
-rw-r--r--textproc/unoconv/files/pkg-message.in11
-rw-r--r--textproc/unoconv/files/unoconv.in7
-rw-r--r--textproc/unoconv/pkg-descr9
-rw-r--r--textproc/unoconv/pkg-plist14
6 files changed, 108 insertions, 0 deletions
diff --git a/textproc/unoconv/Makefile b/textproc/unoconv/Makefile
new file mode 100644
index 000000000000..5a6e091e37a9
--- /dev/null
+++ b/textproc/unoconv/Makefile
@@ -0,0 +1,65 @@
+# $FreeBSD$
+
+PORTNAME= unoconv
+PORTVERSION= 0.6
+CATEGORIES= textproc python
+MASTER_SITES= http://dag.wieers.com/home-made/unoconv/
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Convert any document from and to any LibreOffice supported format
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PORTDATA= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog README.asciidoc WISHLIST
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= errcode.txt filters.txt formats.txt office-installations.txt \
+ selinux.txt unoconv.1.txt
+
+MAN1= ${PORTNAME}.1
+
+SUB_FILES= ${PORTNAME} pkg-message
+
+.include <bsd.port.options.mk>
+
+do-install:
+# Scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+# Executable
+ ${MKDIR} ${DATADIR}/tests
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${DATADIR}
+
+# Data
+.for f in *.odt *.csv
+ @(cd ${WRKSRC}/tests && ${INSTALL_DATA} ${f} ${DATADIR}/tests)
+.endfor
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/tests/dag.gif ${PREFIX}/share/pixmaps/${PORTNAME}.gif
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+.endif
+
+# pkg-message
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/textproc/unoconv/distinfo b/textproc/unoconv/distinfo
new file mode 100644
index 000000000000..b06df627f474
--- /dev/null
+++ b/textproc/unoconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/unoconv-0.6.tar.gz) = 790e614b8615217ef4588b187f0018b526ec2bb480c6b9b2ffb9b82f48da73d4
+SIZE (python/unoconv-0.6.tar.gz) = 91578
diff --git a/textproc/unoconv/files/pkg-message.in b/textproc/unoconv/files/pkg-message.in
new file mode 100644
index 000000000000..35b29a6c1a47
--- /dev/null
+++ b/textproc/unoconv/files/pkg-message.in
@@ -0,0 +1,11 @@
+===============================================================================
+
+Universal Office Converter (unoconv) has been installed.
+
+For Document conversions is needed that is LibreOffice or OpenOffice installed
+
+editors/libreoffice
+
+editors/openoffice*
+
+===============================================================================
diff --git a/textproc/unoconv/files/unoconv.in b/textproc/unoconv/files/unoconv.in
new file mode 100644
index 000000000000..394215075428
--- /dev/null
+++ b/textproc/unoconv/files/unoconv.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+./unoconv "$@"
diff --git a/textproc/unoconv/pkg-descr b/textproc/unoconv/pkg-descr
new file mode 100644
index 000000000000..d4c9764dd113
--- /dev/null
+++ b/textproc/unoconv/pkg-descr
@@ -0,0 +1,9 @@
+Universal Office Converter (unoconv) is a command line tool to convert any
+document format that LibreOffice can import to any document format that
+LibreOffice can export. It makes use of the LibreOffice's UNO bindings for
+non-interactive conversion of documents.
+
+For practical reasons we mention LibreOffice, but OpenOffice is supported by
+unoconv as well.
+
+WWW: http://dag.wieers.com/home-made/unoconv/
diff --git a/textproc/unoconv/pkg-plist b/textproc/unoconv/pkg-plist
new file mode 100644
index 000000000000..a8826c49ebca
--- /dev/null
+++ b/textproc/unoconv/pkg-plist
@@ -0,0 +1,14 @@
+bin/unoconv
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README.asciidoc
+%%PORTDOCS%%%%DOCSDIR%%/WISHLIST
+%%PORTDOCS%%%%DOCSDIR%%/doc/errcode.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/filters.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/formats.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/office-installations.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/selinux.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/unoconv.1.txt
+share/pixmaps/unoconv.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%