aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/unroff/files
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1996-04-10 14:38:59 +0800
committertg <tg@FreeBSD.org>1996-04-10 14:38:59 +0800
commit8e62d8e5cf96bc43265d6d9cf8895ad614027da7 (patch)
tree80228121f00d0597d19a2069c427b0c99ce0ee4c /textproc/unroff/files
parent454a94754a14ebe26900c46ac1b98919ce91d82b (diff)
downloadfreebsd-ports-gnome-8e62d8e5cf96bc43265d6d9cf8895ad614027da7.tar.gz
freebsd-ports-gnome-8e62d8e5cf96bc43265d6d9cf8895ad614027da7.tar.zst
freebsd-ports-gnome-8e62d8e5cf96bc43265d6d9cf8895ad614027da7.zip
Import unroff, a programmable, extensible troff converter with
HTML backend.
Diffstat (limited to 'textproc/unroff/files')
-rw-r--r--textproc/unroff/files/patch-a68
-rw-r--r--textproc/unroff/files/patch-b15
2 files changed, 83 insertions, 0 deletions
diff --git a/textproc/unroff/files/patch-a b/textproc/unroff/files/patch-a
new file mode 100644
index 000000000000..26329063a10c
--- /dev/null
+++ b/textproc/unroff/files/patch-a
@@ -0,0 +1,68 @@
+diff -cr unroff-1.0.orig/src/Makefile unroff-1.0/src/Makefile
+*** unroff-1.0.orig/src/Makefile Wed Aug 23 14:12:48 1995
+--- unroff-1.0/src/Makefile Mon Feb 12 18:51:08 1996
+***************
+*** 1,14 ****
+ # $Revision: 1.12 $
+
+ ### You need a C compiler that compiles ANSI C code.
+! CC = gcc
+! CFLAGS = -Wall -pedantic -O
+
+ ### If you need additional linker flags add them here.
+! LDFLAGS =
+
+ ### The directory where the Elk installation resides on your system.
+! ELKDIR = /usr/elk
+
+ ### Additional libraries. You may want to insert the output of the
+ ### shell-script $(ELKDIR)/lib/ldflags here.
+--- 1,14 ----
+ # $Revision: 1.12 $
+
+ ### You need a C compiler that compiles ANSI C code.
+! #CC = gcc
+! #CFLAGS = -Wall -pedantic -O
+
+ ### If you need additional linker flags add them here.
+! LDFLAGS = -s
+
+ ### The directory where the Elk installation resides on your system.
+! ELKDIR = ${PREFIX}/share/elk
+
+ ### Additional libraries. You may want to insert the output of the
+ ### shell-script $(ELKDIR)/lib/ldflags here.
+***************
+*** 18,24 ****
+ MAKEDEP = makedepend
+
+ ### The directory under which you will install the Scheme files.
+! DIR = /usr/local/lib/unroff
+
+ ### The default output format.
+ FORMAT = html
+--- 18,24 ----
+ MAKEDEP = makedepend
+
+ ### The directory under which you will install the Scheme files.
+! DIR = ${PREFIX}/share/unroff
+
+ ### The default output format.
+ FORMAT = html
+***************
+*** 30,36 ****
+ ### -------------------------------------------------------------------------
+
+ SHELL = /bin/sh
+! INCLUDE = -I$(ELKDIR)/include
+ ELK = $(ELKDIR)/lib/module.o
+ DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
+ CTAGS = ctags -t -w
+--- 30,36 ----
+ ### -------------------------------------------------------------------------
+
+ SHELL = /bin/sh
+! INCLUDE = -I${PREFIX}/include/elk
+ ELK = $(ELKDIR)/lib/module.o
+ DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
+ CTAGS = ctags -t -w
diff --git a/textproc/unroff/files/patch-b b/textproc/unroff/files/patch-b
new file mode 100644
index 000000000000..d846348ec27b
--- /dev/null
+++ b/textproc/unroff/files/patch-b
@@ -0,0 +1,15 @@
+diff -cr unroff-1.0.orig/src/error.c unroff-1.0/src/error.c
+*** unroff-1.0.orig/src/error.c Fri Jun 2 15:16:00 1995
+--- unroff-1.0/src/error.c Mon Feb 12 18:53:17 1996
+***************
+*** 39,45 ****
+--- 39,47 ----
+
+ static char *strerr(void) {
+ extern int sys_nerr;
++ #ifndef BSD
+ extern char *sys_errlist[];
++ #endif
+
+ return errno > 0 && errno < sys_nerr ?
+ sys_errlist[errno] : "unknown error";