aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/utf8proc/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-10-16 16:39:36 +0800
committerclsung <clsung@FreeBSD.org>2007-10-16 16:39:36 +0800
commit6f283372a09cc430eb5ab7a536ca9ee0341556d4 (patch)
tree11f2d1f602890c9e1ded02920331f8fd3d09b868 /textproc/utf8proc/Makefile
parentd85b6afe1c8dfacf1d357e7f887b03f956d932c3 (diff)
downloadfreebsd-ports-gnome-6f283372a09cc430eb5ab7a536ca9ee0341556d4.tar.gz
freebsd-ports-gnome-6f283372a09cc430eb5ab7a536ca9ee0341556d4.tar.zst
freebsd-ports-gnome-6f283372a09cc430eb5ab7a536ca9ee0341556d4.zip
utf8proc is a library for processing UTF-8 encoded Unicode strings.
Some features are Unicode normalization, stripping of default ignorable characters, case folding and detection of grapheme cluster boundaries. A special character mapping is available, which converts for example the characters "Hyphen" (U+2010), "Minus" (U+2212) and "Hyphen-Minus" (U+002D, ASCII Minus) all into the ASCII minus sign, to make them equal for comparisons. WWW: http://www.flexiguided.de/publications.utf8proc.en.html
Diffstat (limited to 'textproc/utf8proc/Makefile')
-rw-r--r--textproc/utf8proc/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/utf8proc/Makefile b/textproc/utf8proc/Makefile
new file mode 100644
index 000000000000..bcb25f05d55d
--- /dev/null
+++ b/textproc/utf8proc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: utf8proc
+# Date created: 2007-10-15
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= utf8proc
+PORTVERSION= 1.1.2
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.flexiguided.de/pub/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= UTF-8 processing library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= c-library
+
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libutf8proc.so ${PREFIX}/lib/libutf8proc.so.1
+ ${INSTALL_DATA} ${WRKSRC}/libutf8proc.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/utf8proc.h ${PREFIX}/include
+ ${LN} -sf ${PREFIX}/lib/libutf8proc.so.0 ${PREFIX}/lib/libutf8proc.so
+
+.include <bsd.port.mk>