aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/wv/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-12 02:28:26 +0800
committernork <nork@FreeBSD.org>2003-07-12 02:28:26 +0800
commit73dda3124346c56f235485900adaff0f2e665046 (patch)
treed813d741a8b45f1cfdc9eec030a428ac2a88758e /textproc/wv/Makefile
parent826cebe474e1e92e9b7ebdf01227d25f662f5538 (diff)
downloadfreebsd-ports-gnome-73dda3124346c56f235485900adaff0f2e665046.tar.gz
freebsd-ports-gnome-73dda3124346c56f235485900adaff0f2e665046.tar.zst
freebsd-ports-gnome-73dda3124346c56f235485900adaff0f2e665046.zip
Update to 0.7.6.
PR: ports/53584 Submitted by: Ports Fury
Diffstat (limited to 'textproc/wv/Makefile')
-rw-r--r--textproc/wv/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/textproc/wv/Makefile b/textproc/wv/Makefile
index 3a0d38b9be25..ac372a9a75ed 100644
--- a/textproc/wv/Makefile
+++ b/textproc/wv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wv
-PORTVERSION= 0.7.5
+PORTVERSION= 0.7.6
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wvware
@@ -14,19 +14,27 @@ MASTER_SITE_SUBDIR= wvware
MAINTAINER= mzaki@e-mail.ne.jp
COMMENT= A library and executables which allow access to Microsoft Word files
-LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
- iconv.3:${PORTSDIR}/converters/libiconv \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf
RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-libwmf=${LOCALBASE} --with-libiconv=${LOCALBASE} \
- --with-png=${LOCALBASE} --with-exporter --without-glib
+CONFIGURE_ARGS= --with-exporter --without-glib
+MAKEFILE= GNUmakefile
+INSTALLS_SHLIB= yes
MAN1= wvAbw.1 wvCleanLatex.1 wvDVI.1 wvHtml.1 wvLatex.1 wvMime.1 wvPDF.1 \
wvPS.1 wvRTF.1 wvSummary.1 wvText.1 wvVersion.1 wvWare.1 wvWml.1
MLINKS= wvWare.1 wvConvert.1
+CPPFLAGS= -I${LOCALBASE}/include/libpng -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e '/HAVE_MALLOC_H/d' ${WRKSRC}/config.h.in
+
.include <bsd.port.mk>