aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xerces-c27
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-01-12 10:03:09 +0800
committernaddy <naddy@FreeBSD.org>2003-01-12 10:03:09 +0800
commit161c3eae42f360a46b07564003632ad7186dfd78 (patch)
tree14fad616d57e6127f21595f218f292842424fbd5 /textproc/xerces-c27
parentb8cd342adb6af11db84d106feb6eee7d4c034b16 (diff)
downloadfreebsd-ports-gnome-161c3eae42f360a46b07564003632ad7186dfd78.tar.gz
freebsd-ports-gnome-161c3eae42f360a46b07564003632ad7186dfd78.tar.zst
freebsd-ports-gnome-161c3eae42f360a46b07564003632ad7186dfd78.zip
Fix building on sparc64 and alpha.
Thanks to Mikko Tyolajarvi for fixing and testing on sparc64. PR: 46636 Submitted by: Bjoern A. Zeeb <bzeeb+freebsdports@zabbadoz.net>
Diffstat (limited to 'textproc/xerces-c27')
-rw-r--r--textproc/xerces-c27/Makefile8
-rw-r--r--textproc/xerces-c27/Makefile.alpha10
-rw-r--r--textproc/xerces-c27/Makefile.sparc6414
-rw-r--r--textproc/xerces-c27/files/patch-aa12
4 files changed, 41 insertions, 3 deletions
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index fda5c2cc1c8f..976e31423fb4 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -55,10 +55,12 @@ MAKE_ENV+= XERCESCROOT=${WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER=${TRANSCODER}
CONFIGURE_SCRIPT= runConfigure
-CONFIGURE_ARGS?= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
+CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
+.include <bsd.port.pre.mk>
+
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.endif
@@ -73,7 +75,7 @@ PLIST_SUB+= NO_SAMPLES=""
ALL_TARGET?= all samples
XERCES_BINS?= CreateDOMDocument DOMCount DOMPrint EnumVal MemParse PParse \
Redirect SAX2Count SAX2Print SAXCount SAXPrint SEnumVal StdInParse
-SAMPLES_CONFIG_ARGS?= -p freebsd -x g++
+SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
.if defined(NO_THREADS)
SAMPLES_CONFIG_ARGS+= -r none
.endif
@@ -143,4 +145,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/xerces-c27/Makefile.alpha b/textproc/xerces-c27/Makefile.alpha
new file mode 100644
index 000000000000..874bb0a96fca
--- /dev/null
+++ b/textproc/xerces-c27/Makefile.alpha
@@ -0,0 +1,10 @@
+# Date created: 29 December 2002
+# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
+#
+# $FreeBSD$
+#
+
+# set bitsToBuild to 64
+CONFIGURE_ARGS+= -b 64
+SAMPLES_CONFIG_ARGS+= -b 64
+
diff --git a/textproc/xerces-c27/Makefile.sparc64 b/textproc/xerces-c27/Makefile.sparc64
new file mode 100644
index 000000000000..f5c5a7e8a47e
--- /dev/null
+++ b/textproc/xerces-c27/Makefile.sparc64
@@ -0,0 +1,14 @@
+# Date created: 26 December 2002
+# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
+#
+# $FreeBSD$
+#
+
+# When there are no probs with libc_r / pthreads on sparc64-freebsd we
+# should remove this files or make it conditional on OSVERSION
+NO_THREADS= yes
+
+# set bitsToBuild to 64
+CONFIGURE_ARGS+= -b 64
+SAMPLES_CONFIG_ARGS+= -b 64
+
diff --git a/textproc/xerces-c27/files/patch-aa b/textproc/xerces-c27/files/patch-aa
new file mode 100644
index 000000000000..1e3aad521e00
--- /dev/null
+++ b/textproc/xerces-c27/files/patch-aa
@@ -0,0 +1,12 @@
+--- src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp.orig Tue Aug 27 09:24:38 2002
++++ src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp Sun Jan 12 01:44:04 2003
+@@ -1091,7 +1091,8 @@
+ // perform conversion
+ wLent *= uChSize();
+ char *ptr = retVal;
+- size_t rc = iconvTo(wideCharBuf, &wLent, &ptr, neededLen);
++ size_t tmpwLent = wLent;
++ size_t rc = iconvTo(wideCharBuf, &tmpwLent, &ptr, neededLen);
+ if (rc == (size_t)-1) {
+ if (wBufPtr)
+ delete [] wBufPtr;