aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xlhtml
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-12-13 08:34:18 +0800
committersergei <sergei@FreeBSD.org>2003-12-13 08:34:18 +0800
commit135124a5a7d898f90f44feabbcb3aa8bf5789bd1 (patch)
tree094a57f3d2828dbbc7e2a278e39531f2afea52af /textproc/xlhtml
parentd9c3214d2095212e38ac9378bada3bc8145852eb (diff)
downloadfreebsd-ports-gnome-135124a5a7d898f90f44feabbcb3aa8bf5789bd1.tar.gz
freebsd-ports-gnome-135124a5a7d898f90f44feabbcb3aa8bf5789bd1.tar.zst
freebsd-ports-gnome-135124a5a7d898f90f44feabbcb3aa8bf5789bd1.zip
- Patch browser helper utilities nsopen, nsxlview, and nsppptview
so that they work PR: 53662 Submitted by: John Merryweather Cooper <coop9211@uidaho.edu>
Diffstat (limited to 'textproc/xlhtml')
-rw-r--r--textproc/xlhtml/Makefile1
-rw-r--r--textproc/xlhtml/files/patch-ppthtml_nspptview23
-rw-r--r--textproc/xlhtml/files/patch-xlhtml_nsopen14
-rw-r--r--textproc/xlhtml/files/patch-xlhtml_nsxlview15
4 files changed, 53 insertions, 0 deletions
diff --git a/textproc/xlhtml/Makefile b/textproc/xlhtml/Makefile
index 8aa83f852c3c..ea6595f17a49 100644
--- a/textproc/xlhtml/Makefile
+++ b/textproc/xlhtml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xlhtml
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://chicago.sourceforge.net/xlhtml/
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/textproc/xlhtml/files/patch-ppthtml_nspptview b/textproc/xlhtml/files/patch-ppthtml_nspptview
new file mode 100644
index 000000000000..08cf0894e2c8
--- /dev/null
+++ b/textproc/xlhtml/files/patch-ppthtml_nspptview
@@ -0,0 +1,23 @@
+--- ppthtml/nspptview.orig Sun Jun 22 08:47:02 2003
++++ ppthtml/nspptview Sun Jun 22 08:49:18 2003
+@@ -1,7 +1,7 @@
+ #!/bin/csh
+
+ if ($#argv != 1) then
+- echo "Usage: $0 file.doc"
++ echo "Usage: $0 file.ppt"
+ exit 1
+ endif
+
+@@ -12,9 +12,8 @@
+ #set tmp = /tmp/$com:t.$$
+ #set html = $tmp.html
+
+-set tmp = `mktemp -q /tmp/nspptview.XXXXXX` || exit 1
+-set tmp2 = `mktemp -q $tmp/nspptview.XXXXXX` || exit 1
+-set html = $tmp2.html
++set tmp = `mktemp -t nspptview.XXXXXX` || exit 1
++set html = $tmp.html
+
+ ppthtml $source > $html
+ if ((!(-r $html)) | ($status)) then
diff --git a/textproc/xlhtml/files/patch-xlhtml_nsopen b/textproc/xlhtml/files/patch-xlhtml_nsopen
new file mode 100644
index 000000000000..197e1e4bd74a
--- /dev/null
+++ b/textproc/xlhtml/files/patch-xlhtml_nsopen
@@ -0,0 +1,14 @@
+--- xlhtml/nsopen.orig Sun Jun 22 01:17:52 2003
++++ xlhtml/nsopen Sun Jun 22 01:18:51 2003
+@@ -12,9 +12,9 @@
+ endif
+
+ #Try to open file in an existing netscape window
+-(netscape -no-about-splash -remote "openFile(${file})") >& /dev/null
++(mozilla -remote "openFile(${file})") >& /dev/null
+
+ #if this fails, it means that netscape is not running, so start it
+ if ($status) then
+- netscape -no-about-splash -no-install file:${file}
++ mozilla file:${file}
+ endif
diff --git a/textproc/xlhtml/files/patch-xlhtml_nsxlview b/textproc/xlhtml/files/patch-xlhtml_nsxlview
new file mode 100644
index 000000000000..1b174aacc5ad
--- /dev/null
+++ b/textproc/xlhtml/files/patch-xlhtml_nsxlview
@@ -0,0 +1,15 @@
+--- xlhtml/nsxlview.orig Sun Jun 22 08:36:31 2003
++++ xlhtml/nsxlview Sun Jun 22 08:44:57 2003
+@@ -12,10 +12,8 @@
+ #set tmp = /tmp/$com:t.$$
+ #set html = $tmp.html
+
+-set tmp = `mktemp -q /tmp/nsxlview.XXXXXX` || exit 1
+-set tmp2 = `mktemp -q $tmp/nsxlview.XXXXXX` || exit 1
+-set html = $tmp2.html
+-
++set tmp = `mktemp -t nsxlview.XXXXXX` || exit 1
++set html = $tmp.html
+
+ xlhtml -a $source > $html
+ if ((!(-r $html)) | ($status)) then