aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xmldiff
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-02-11 15:35:58 +0800
committerjylefort <jylefort@FreeBSD.org>2006-02-11 15:35:58 +0800
commitf04e9f0bf13aaf6adf47288e5ad4995ddc1dbfa2 (patch)
tree2998e1882a7d73410ed1cbf731e171504b4384d1 /textproc/xmldiff
parentb4463b5de659794c99cc167c71dff6421a4957d8 (diff)
downloadfreebsd-ports-gnome-f04e9f0bf13aaf6adf47288e5ad4995ddc1dbfa2.tar.gz
freebsd-ports-gnome-f04e9f0bf13aaf6adf47288e5ad4995ddc1dbfa2.tar.zst
freebsd-ports-gnome-f04e9f0bf13aaf6adf47288e5ad4995ddc1dbfa2.zip
Add xmldiff.
xmldiff uses xmlprpr and diff to display meaningful differences in XML files in an easy to read format. Output formats available include HTML, ANSI colour, and regular diff. The coloured modes are particularly useful for viewing small differences in context within large XML files. WWW: http://software.decisionsoft.com/tools.html PR: ports/92947 Submitted by: Paul Chvostek <paul+ports@it.ca>
Diffstat (limited to 'textproc/xmldiff')
-rw-r--r--textproc/xmldiff/Makefile31
-rw-r--r--textproc/xmldiff/distinfo3
-rw-r--r--textproc/xmldiff/files/patch-xmldiff.pl17
-rw-r--r--textproc/xmldiff/pkg-descr9
4 files changed, 60 insertions, 0 deletions
diff --git a/textproc/xmldiff/Makefile b/textproc/xmldiff/Makefile
new file mode 100644
index 000000000000..4fb1b7954d95
--- /dev/null
+++ b/textproc/xmldiff/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xmldiff
+# Date created: Sun Oct 9 10:33:37 EDT 2005
+# Whom: Paul Chvostek <paul+ports@it.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmldiff
+PORTVERSION= 0.01
+CATEGORIES= textproc
+MASTER_SITES= http://software.decisionsoft.com/software/ \
+ http://www.it.ca/~paul/src/
+DISTFILES= xmldiff.pl
+
+MAINTAINER= paul+ports@it.ca
+COMMENT= Display meaningful differences between XML files
+
+RUN_DEPENDS= xmlprpr:${PORTSDIR}/textproc/xmlprpr
+
+USE_PERL5= yes
+NO_BUILD= yes
+PLIST_FILES= bin/xmldiff
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -f ${_DISTDIR}/${_DISTFILES} ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/xmldiff.pl ${PREFIX}/bin/xmldiff
+
+.include <bsd.port.mk>
diff --git a/textproc/xmldiff/distinfo b/textproc/xmldiff/distinfo
new file mode 100644
index 000000000000..54540bb01126
--- /dev/null
+++ b/textproc/xmldiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmldiff.pl) = e51781dea77a3a35e5f981dcf17a033a
+SHA256 (xmldiff.pl) = c825e77068bcabfe524ee4fe78d87cbc013e6162d0ac298c854379f7ecefa4f4
+SIZE (xmldiff.pl) = 2976
diff --git a/textproc/xmldiff/files/patch-xmldiff.pl b/textproc/xmldiff/files/patch-xmldiff.pl
new file mode 100644
index 000000000000..9b0ea24d1cec
--- /dev/null
+++ b/textproc/xmldiff/files/patch-xmldiff.pl
@@ -0,0 +1,17 @@
+--- xmldiff.pl.orig Sat Feb 11 08:32:29 2006
++++ xmldiff.pl Sat Feb 11 08:32:38 2006
+@@ -7,12 +7,12 @@
+ #
+
+ #
+-# xmldiff: xmldiff program - uses xmlpp
++# xmldiff: xmldiff program - uses xmlprpr
+ #
+
+ #Change this if xmlpp is not in your current path
+ #for example: $XMLPP = "./xmlpp";
+-$XMLPP = "xmlpp";
++$XMLPP = "xmlprpr";
+
+ # older versions of less don't support -R, consider -r instead
+ my $pagerCmd = ' | less -R ';
diff --git a/textproc/xmldiff/pkg-descr b/textproc/xmldiff/pkg-descr
new file mode 100644
index 000000000000..7e4cdcc84ab9
--- /dev/null
+++ b/textproc/xmldiff/pkg-descr
@@ -0,0 +1,9 @@
+xmldiff uses xmlprpr and diff to display meaningful differences in XML
+files in an easy to read format. Output formats available include HTML,
+ANSI colour, and regular diff. The coloured modes are particularly
+useful for viewing small differences in context within large XML files.
+
+WWW: http://software.decisionsoft.com/tools.html
+
+- Paul Chvostek
+paul+ports@it.ca