aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xmlroff/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-01-10 08:39:55 +0800
committermezz <mezz@FreeBSD.org>2005-01-10 08:39:55 +0800
commitfe858a2f2a80e0e45bd57c7e6270556a77050c4e (patch)
tree10d26903fd48223006f670fe0fde8d6860554b1a /textproc/xmlroff/Makefile
parentfbf0c373925d83985327af2be60d14e04a50308b (diff)
downloadfreebsd-ports-gnome-fe858a2f2a80e0e45bd57c7e6270556a77050c4e.tar.gz
freebsd-ports-gnome-fe858a2f2a80e0e45bd57c7e6270556a77050c4e.tar.zst
freebsd-ports-gnome-fe858a2f2a80e0e45bd57c7e6270556a77050c4e.zip
xmlroff is an XSL formatter written in C that produces PDF and PostScript.
WWW: http://xmlroff.org PR: ports/75972 Submitted by: James Earl <james@icionline.ca>
Diffstat (limited to 'textproc/xmlroff/Makefile')
-rw-r--r--textproc/xmlroff/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/xmlroff/Makefile b/textproc/xmlroff/Makefile
new file mode 100644
index 000000000000..eb2d94cdcf4d
--- /dev/null
+++ b/textproc/xmlroff/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xmlroff
+# Date created: 1 January 2005
+# Whom: James Earl
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlroff
+PORTVERSION= 0.3.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= chero7@telus.net
+COMMENT= XSL formatter that produces PDF and PostScript
+
+LIB_DEPENDS= pangoxsl-1.0.600:${PORTSDIR}/x11-toolkits/pangoxsl
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget libgnomeprint
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>