aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xmlwrapp
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-13 18:37:17 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-13 18:37:17 +0800
commitf783abd6b76f89353c8dc913d5e906b0f7cfbf31 (patch)
tree86710de8aee5e52f7f427630a2ea1ebbd9a1fa82 /textproc/xmlwrapp
parent7e40007d8d4494018ffa922effb4fb89e3fdacb4 (diff)
downloadfreebsd-ports-gnome-f783abd6b76f89353c8dc913d5e906b0f7cfbf31.tar.gz
freebsd-ports-gnome-f783abd6b76f89353c8dc913d5e906b0f7cfbf31.tar.zst
freebsd-ports-gnome-f783abd6b76f89353c8dc913d5e906b0f7cfbf31.zip
add xslt support
Diffstat (limited to 'textproc/xmlwrapp')
-rw-r--r--textproc/xmlwrapp/Makefile8
-rw-r--r--textproc/xmlwrapp/pkg-plist14
2 files changed, 15 insertions, 7 deletions
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index 9e4b7e0a751b..e2da7f0ab102 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -22,4 +22,12 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
INSTALLS_SHLIB= yes
+.if defined(WITH_XSLT)
+LIB_DEPENDS+= xslt.1:${PORTSDIR}/textproc/libxslt
+PLIST_SUB+= XSLT=""
+.else
+CONFIGURE_ARGS+= --disable-xslt
+PLIST_SUB+= XSLT="@comment "
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/xmlwrapp/pkg-plist b/textproc/xmlwrapp/pkg-plist
index 8b373ab011ea..a74e09e68358 100644
--- a/textproc/xmlwrapp/pkg-plist
+++ b/textproc/xmlwrapp/pkg-plist
@@ -7,15 +7,15 @@ include/xmlwrapp/init.h
include/xmlwrapp/node.h
include/xmlwrapp/tree_parser.h
include/xmlwrapp/xmlwrapp.h
-include/xsltwrapp/xsltwrapp.h
-include/xsltwrapp/stylesheet.h
-include/xsltwrapp/init.h
@dirrm include/xmlwrapp
-@dirrm include/xsltwrapp
+%%XSLT%%include/xsltwrapp/xsltwrapp.h
+%%XSLT%%include/xsltwrapp/stylesheet.h
+%%XSLT%%include/xsltwrapp/init.h
+%%XSLT%%@dirrm include/xsltwrapp
lib/libxmlwrapp.a
lib/libxmlwrapp.so
lib/libxmlwrapp.so.4
-lib/libxsltwrapp.a
-lib/libxsltwrapp.so
-lib/libxsltwrapp.so.1
+%%XSLT%%lib/libxsltwrapp.a
+%%XSLT%%lib/libxsltwrapp.so
+%%XSLT%%lib/libxsltwrapp.so.1
lib/pkgconfig/xmlwrapp.pc