aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xp/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-10-06 07:15:23 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-10-06 07:15:23 +0800
commit0a2d44498bc7009dcb3956792a37ca06f4172ef5 (patch)
treeee3377116e0e48f9fe1a4d8a070f12ca4e96d128 /textproc/xp/Makefile
parente2aec8ffb4b3ba5354629f5c3f12facbe356a6cc (diff)
downloadfreebsd-ports-gnome-0a2d44498bc7009dcb3956792a37ca06f4172ef5.tar.gz
freebsd-ports-gnome-0a2d44498bc7009dcb3956792a37ca06f4172ef5.tar.zst
freebsd-ports-gnome-0a2d44498bc7009dcb3956792a37ca06f4172ef5.zip
XP is an XML 1.0 parser written in Java. It is fully conforming: it
detects all non well-formed documents. XP has the following design goals: Conformance and correctness, high performance and a layered structure. Is is currently non-validating but can parse all external entities. PR: 13875 Submitted by: mike@vee.net
Diffstat (limited to 'textproc/xp/Makefile')
-rw-r--r--textproc/xp/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/xp/Makefile b/textproc/xp/Makefile
new file mode 100644
index 000000000000..a42685ff25f6
--- /dev/null
+++ b/textproc/xp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xp
+# Version required: 0.5
+# Date created: 21 September 1999
+# Whom: mike
+#
+# $FreeBSD$
+#
+
+DISTNAME= xp
+PKGNAME= xp-0.5
+CATEGORIES= textproc java
+MASTER_SITES= ftp://ftp.jclark.com/pub/xml/
+
+MAINTAINER= mike@vee.net
+
+RUN_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk
+
+XP_VERSION= 0.5
+PLIST_SUB+= XP_VERSION=${XP_VERSION}
+
+NO_WORKSUBDIR= yes
+NO_BUILD= yes
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/java/classes ${PREFIX}/share/java/${PKGNAME}
+ ${INSTALL_DATA} \
+ ${WRKDIR}/xp.jar \
+ ${PREFIX}/share/java/classes/${PKGNAME}.jar
+ cd ${WRKDIR}; \
+ ${CP} -R docs ${PREFIX}/share/java/${PKGNAME}; \
+ ${CP} -R com ${PREFIX}/share/java/${PKGNAME}
+
+.include <bsd.port.post.mk>