aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xt
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-06 12:34:23 +0800
committeradamw <adamw@FreeBSD.org>2014-08-06 12:34:23 +0800
commita46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8 (patch)
treed206a205dd3870d245c26875f1da2aaa627aad64 /textproc/xt
parent0a17597462ff11896ad3e619b25fc9df0263fcef (diff)
downloadfreebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.tar.gz
freebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.tar.zst
freebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.zip
In some straightforward situations, protect examples behind PORTEXAMPLES,
adding EXAMPLES to OPTIONS_DEFINE where necessary. In a couple instances, correct examples being controlled by the DOCS option.
Diffstat (limited to 'textproc/xt')
-rw-r--r--textproc/xt/Makefile10
-rw-r--r--textproc/xt/pkg-plist22
2 files changed, 16 insertions, 16 deletions
diff --git a/textproc/xt/Makefile b/textproc/xt/Makefile
index 69ae1b67521e..f3b84eca6df6 100644
--- a/textproc/xt/Makefile
+++ b/textproc/xt/Makefile
@@ -19,7 +19,7 @@ USE_JAVA= YES
JAVA_VERSION= 1.6+
NO_BUILD= YES
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
OTHERDOCS= copying.txt copyingjc.txt index.html
PORTDOCS= ${OTHERDOCS} api
@@ -41,13 +41,13 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Installing samples in ${EXAMPLESDIR}..."
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/demo && ${INSTALL_DATA} ${SAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
+ (cd ${WRKSRC}/demo && ${INSTALL_DATA} ${SAMPLES} ${STAGEDIR}${EXAMPLESDIR}/)
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Installing documentation in ${DOCSDIR}..."
${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${FIND} api \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1
- cd ${WRKSRC} && ${INSTALL_DATA} ${OTHERDOCS} ${STAGEDIR}${DOCSDIR}/
+ (cd ${WRKSRC}/doc && ${FIND} api \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1)
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${OTHERDOCS} ${STAGEDIR}${DOCSDIR}/)
@${ECHO_MSG} " [ DONE ]"
.include <bsd.port.mk>
diff --git a/textproc/xt/pkg-plist b/textproc/xt/pkg-plist
index d8148b556d18..989b2ffef991 100644
--- a/textproc/xt/pkg-plist
+++ b/textproc/xt/pkg-plist
@@ -2,14 +2,14 @@ bin/xt
bin/xt-xml4j
bin/xt-xp
%%JAVAJARDIR%%/xt.jar
-%%EXAMPLESDIR%%/date.xsl
-%%EXAMPLESDIR%%/nxml.xsl
-%%EXAMPLESDIR%%/slides.xml
-%%EXAMPLESDIR%%/slides.xsl
-%%EXAMPLESDIR%%/sort-uniq.xml
-%%EXAMPLESDIR%%/sort-uniq.xsl
-%%EXAMPLESDIR%%/split.xml
-%%EXAMPLESDIR%%/split.xsl
-%%EXAMPLESDIR%%/textfile.xml
-%%EXAMPLESDIR%%/textfile.xsl
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/date.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nxml.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slides.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slides.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sort-uniq.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sort-uniq.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/split.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/split.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textfile.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textfile.xsl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%