aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xxdiff/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-07 18:40:30 +0800
committerpetef <petef@FreeBSD.org>2001-11-07 18:40:30 +0800
commitb132049cfc4cd9eff65ccf7593715f2bbf682aae (patch)
treef90db8ad53e5d49a5770a7db4ca5f3e5008b2de8 /textproc/xxdiff/Makefile
parent551f40ac1d14b7ce35d49de618b339282804fda8 (diff)
downloadfreebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.tar.gz
freebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.tar.zst
freebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.zip
Add xxdiff-2.0, a QT interface to view/merge differences between 2 or
3 files.
Diffstat (limited to 'textproc/xxdiff/Makefile')
-rw-r--r--textproc/xxdiff/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/xxdiff/Makefile b/textproc/xxdiff/Makefile
new file mode 100644
index 000000000000..1cd92b54b4d3
--- /dev/null
+++ b/textproc/xxdiff/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xxdiff
+# Date created: 11 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xxdiff
+PORTVERSION= 2.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= petef@FreeBSD.org
+
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
+USE_GMAKE= yes
+USE_QT_VER= 2
+TMAKEENV= TMAKEPATH=${LOCALBASE}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
+MAKE_ENV+= QTDIR=${X11BASE} PTHREAD_LIBS=${PTHREAD_LIBS}
+WRKSRC= ${WRKDIR}/xxdiff-${PORTVERSION}/src
+
+do-build:
+ (cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile xxdiff.pro)
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xxdiff ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${WRKSRC}/xxdiff --help-html > ${WRKDIR}/xxdiff.html
+ ${INSTALL_DATA} ${WRKDIR}/xxdiff.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>