aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
commit9e393f4b3db656d0acb466d9fa3f9888cb501ddc (patch)
treeeee5b882c5b82c2ca4dc978b8c472738369c1655 /textproc
parentd17a363e6665033194d363b3fe95be83bb36c24e (diff)
downloadfreebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.gz
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.zst
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.zip
Finish fixing broken ports after r404856 and r404694.
* multimedia/obs-studio: Import some upstream commits that pass all required include directories to the compiler and reference libsysinfo.so with a full path instead of passing -lsysinfo and relying on ${LOCALBASE}/lib being in the linker search path. * textproc/sigil: Pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that upstream's build system references libhunspell-1.3.so and libpcre16.so without full paths (instead of finding them with the proper CMake commands it relies on pkg-config's output). * x11/antimicro: Also pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that several X11 and SDL2 libraries are referenced without full paths. I sent a pull request upstream to fix the X11 references, but SDL2 is still detected through pkg-config. MFH: 2015Q4
Diffstat (limited to 'textproc')
-rw-r--r--textproc/sigil/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 9a42b6ab8c58..3febab7bb59d 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -18,6 +18,11 @@ USE_GITHUB= yes
GH_ACCOUNT= Sigil-Ebook
GH_PROJECT= Sigil
+# Upstream uses pkg-config output to pass libhunspell-1.3.so and
+# libpcre16.so to the linker. pkg-config output does not include full
+# paths, so add a workaround to keep the port linking for now.
+LDFLAGS+= -L${LOCALBASE}/lib
+
USES= cmake compiler:c++11-lib desktop-file-utils pkgconfig \
python:3 shebangfix
SHEBANG_FILES= src/Resource_Files/plugin_launchers/python/*.py \