aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-23 06:10:52 +0800
committermiwi <miwi@FreeBSD.org>2009-08-23 06:10:52 +0800
commit048f01387ccde4248e31638967ecd76979ddede4 (patch)
tree1aeb066a067167324c83e9ec456fcd07358bae33 /textproc
parentf1d1b457a67760b86b9dd140b18868db50b12046 (diff)
downloadfreebsd-ports-gnome-048f01387ccde4248e31638967ecd76979ddede4.tar.gz
freebsd-ports-gnome-048f01387ccde4248e31638967ecd76979ddede4.tar.zst
freebsd-ports-gnome-048f01387ccde4248e31638967ecd76979ddede4.zip
Library to create spreadsheet files compatible with
MS Excel 97/2000/XP/2003 XLS files, on any platform, with Python 2.3 to 2.6 xlwt is a library for generating spreadsheet files that are compatible with Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric. xlwt has full support for Unicode. Excel spreadsheets can be generated on any platform without needing Excel or a COM server. The only requirement is Python 2.3 to 2.6. xlwt is a fork of pyExcelerator. WWW: http://www.python-excel.org/ PR: ports/137969 Submitted by: Dikshie
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-xlwt/Makefile19
-rw-r--r--textproc/py-xlwt/distinfo3
-rw-r--r--textproc/py-xlwt/pkg-descr11
-rw-r--r--textproc/py-xlwt/pkg-plist152
5 files changed, 186 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 19938bc0a9d6..6bdbc2bbd301 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -951,6 +951,7 @@
SUBDIR += py-wordnet
SUBDIR += py-xlrd
SUBDIR += py-xlwriter
+ SUBDIR += py-xlwt
SUBDIR += py-xml
SUBDIR += py-xmltools
SUBDIR += py-xmltv
diff --git a/textproc/py-xlwt/Makefile b/textproc/py-xlwt/Makefile
new file mode 100644
index 000000000000..c574b5a3e1ce
--- /dev/null
+++ b/textproc/py-xlwt/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: xlwt
+# Date created: 2009-08-19
+# Whom: Dikshie
+#
+# $FreeBSD$
+
+PORTNAME= xlwt
+PORTVERSION= 0.7.2
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= Writing data and formatting information from Excel files
+
+USE_PYTHON= 2.5-2.6
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-xlwt/distinfo b/textproc/py-xlwt/distinfo
new file mode 100644
index 000000000000..62889ce6540b
--- /dev/null
+++ b/textproc/py-xlwt/distinfo
@@ -0,0 +1,3 @@
+MD5 (xlwt-0.7.2.tar.gz) = ed4b529b883a60b1b887fa30f31823f3
+SHA256 (xlwt-0.7.2.tar.gz) = 4dfbacf77e1b9e760621a8d63cd1e799fb046087a9f2a81b40d300c425e0a056
+SIZE (xlwt-0.7.2.tar.gz) = 114736
diff --git a/textproc/py-xlwt/pkg-descr b/textproc/py-xlwt/pkg-descr
new file mode 100644
index 000000000000..1c3e6619cd3d
--- /dev/null
+++ b/textproc/py-xlwt/pkg-descr
@@ -0,0 +1,11 @@
+Library to create spreadsheet files compatible with
+MS Excel 97/2000/XP/2003 XLS files, on any platform, with Python 2.3
+to 2.6
+
+xlwt is a library for generating spreadsheet files that are compatible
+with Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric. xlwt
+has full support for Unicode. Excel spreadsheets can be generated on
+any platform without needing Excel or a COM server. The only
+requirement is Python 2.3 to 2.6. xlwt is a fork of pyExcelerator.
+
+WWW: http://www.python-excel.org/
diff --git a/textproc/py-xlwt/pkg-plist b/textproc/py-xlwt/pkg-plist
new file mode 100644
index 000000000000..e81ed904623f
--- /dev/null
+++ b/textproc/py-xlwt/pkg-plist
@@ -0,0 +1,152 @@
+lib/%%PYTHON_VERSION%%/site-packages/xlwt-0.7.2-py2.6.egg-info
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/BIFFRecords.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/BIFFRecords.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/BIFFRecords.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Bitmap.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Bitmap.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Bitmap.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Cell.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Cell.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Cell.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Column.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Column.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Column.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/CompoundDoc.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/CompoundDoc.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/CompoundDoc.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormula.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormula.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormula.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaLexer.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaLexer.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaLexer.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaParser.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaParser.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelFormulaParser.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelMagic.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelMagic.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/ExcelMagic.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Formatting.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Formatting.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Formatting.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Row.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Row.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Row.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Style.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Style.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Style.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/UnicodeUtils.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/UnicodeUtils.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/UnicodeUtils.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Utils.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Utils.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Utils.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Workbook.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Workbook.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Workbook.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Worksheet.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Worksheet.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/Worksheet.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/antlr.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/antlr.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/antlr.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/doc/xlwt.html
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-16Mb.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-16Mb.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-16Mb.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-35Mb.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-35Mb.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/big-35Mb.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/blanks.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/blanks.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/blanks.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/col_width.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/col_width.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/col_width.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/country.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/country.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/country.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/dates.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/dates.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/dates.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/format.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/format.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/format.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formula_names.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formula_names.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formula_names.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formulas.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formulas.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/formulas.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/hyperlinks.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/hyperlinks.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/hyperlinks.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/image.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/image.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/image.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged0.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged0.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged0.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged1.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged1.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/merged1.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/mini.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/mini.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/mini.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/num_formats.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/num_formats.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/num_formats.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/numbers.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/numbers.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/numbers.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/outline.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/outline.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/outline.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/panes.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/panes.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/panes.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/parse-fmla.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/parse-fmla.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/parse-fmla.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/protection.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/protection.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/protection.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/python.bmp
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles_empty.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles_empty.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/row_styles_empty.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/simple.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/simple.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/simple.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/sst.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/sst.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/sst.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode0.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode0.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode0.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode1.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode1.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode1.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode2.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode2.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/unicode2.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/wsprops.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/wsprops.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/wsprops.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/xlwt_easyxf_simple_demo.py
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/xlwt_easyxf_simple_demo.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples/xlwt_easyxf_simple_demo.pyo
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlwt/examples
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlwt/doc
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlwt
+@dirrm lib/%%PYTHON_VERSION%%/site-packages
+@dirrm lib/%%PYTHON_VERSION%%