aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-12-21 04:19:24 +0800
committerbsam <bsam@FreeBSD.org>2009-12-21 04:19:24 +0800
commit0e6ff8502a31c3e7e5131a019b9fc905acb650b8 (patch)
tree42b9f5dcdafced4edba69059ca29b8a02fc12559 /textproc
parent5ffc34ba901be4f5d98415be34c74452ff1aec87 (diff)
downloadfreebsd-ports-gnome-0e6ff8502a31c3e7e5131a019b9fc905acb650b8.tar.gz
freebsd-ports-gnome-0e6ff8502a31c3e7e5131a019b9fc905acb650b8.tar.zst
freebsd-ports-gnome-0e6ff8502a31c3e7e5131a019b9fc905acb650b8.zip
Changes to editors/emacs and Mk/bsd.emacs.mk were taken from
PR/137956 by Ashish SHUKLA (thanks!). [1] Those ports which define EMACS_PORT_NAME to be "emacs21" were not touched (this time). They may be converted to the new world order by removing the above mentioned assignment. Four ports were marked as BROKEN with EMACS_PORT_NAME=emacs23 (they do not compile): . lang/bigloo; . mail/wanderlust; . mail/wanderlust-devel; . www/emacs-w3m. Three ports were marked as IGNORE with EMACS_PORT_NAME=emacs23: . japanese/egg-canna (the port version is dated as of 2001, does not compile with Emacs 23 and seems it cannot be fixed); . deskutils/remember.el (was incorporated into Emacs 23); . editors/nxml (was incorporated into Emacs 23). Changes that were made after (and as a result of) exp run. For those ports: . japanese/migemo-emacs21; . japanese/migemo-emacs22 EMACS_PORT_NAME?= was changed to EMACS_PORT_NAME= to the apropriate emacs port name. PR: ports/137956 [1], ports/141369 [2] Submitted by: Ashish SHUKLA <wahjava at gmail.com> [1], bsam (me) [2] Exp-run by: miwi
Diffstat (limited to 'textproc')
-rw-r--r--textproc/dictem/Makefile1
-rw-r--r--textproc/dictionary/Makefile3
-rw-r--r--textproc/doc-mode.el/Makefile4
-rw-r--r--textproc/muse/Makefile15
-rw-r--r--textproc/uim-el/Makefile1
5 files changed, 12 insertions, 12 deletions
diff --git a/textproc/dictem/Makefile b/textproc/dictem/Makefile
index c3ce183ecac0..146672cb45f2 100644
--- a/textproc/dictem/Makefile
+++ b/textproc/dictem/Makefile
@@ -6,6 +6,7 @@
PORTNAME= dictem
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= textproc net elisp
MASTER_SITES= SF/dictem/dictem/dictem-${PORTVERSION}
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
diff --git a/textproc/dictionary/Makefile b/textproc/dictionary/Makefile
index be014482a2e8..b12cac1b7681 100644
--- a/textproc/dictionary/Makefile
+++ b/textproc/dictionary/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dictionary
PORTVERSION= 1.8.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc net elisp
MASTER_SITES= http://me.in-berlin.de/~myrkr/dictionary/ \
http://bsdchat.com/dist/dryice/
@@ -17,7 +17,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A dictionary client for Emacs
USE_EMACS= yes
-EMACS_PORT_NAME?= emacs22
LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
ELS= connection.el dictionary.el link.el
diff --git a/textproc/doc-mode.el/Makefile b/textproc/doc-mode.el/Makefile
index fd9fa665dcdd..3cdf87bbd22b 100644
--- a/textproc/doc-mode.el/Makefile
+++ b/textproc/doc-mode.el/Makefile
@@ -7,7 +7,7 @@
PORTNAME= doc-mode.el
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc elisp
MASTER_SITES= SF/xpt/doc-mode/doc-mode-${PORTVERSION}
DISTNAME= doc-mode-${PORTVERSION}
@@ -17,8 +17,6 @@ MAINTAINER= peter.schuller@infidyne.com
COMMENT= Asciidoc fontlocking for emacs
USE_EMACS= yes
-EMACS_PORT_NAME?=emacs22
-
NO_BUILD= yes
do-install:
diff --git a/textproc/muse/Makefile b/textproc/muse/Makefile
index b96341f29b8a..820fbee0c2cc 100644
--- a/textproc/muse/Makefile
+++ b/textproc/muse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= muse
PORTVERSION= 3.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc elisp
MASTER_SITES= http://download.gna.org/muse-el/ \
${MASTER_SITE_LOCAL} \
@@ -20,14 +20,9 @@ COMMENT= An authoring and publishing environment for Emacs
USE_EMACS= yes
USE_GMAKE= yes
-EMACS_PORT_NAME?= emacs22
INFO= muse
-.if ${EMACS_PORT_NAME} != "emacs22"
-PORTNAMESUFFIX= ${PKGNAMESUFFIX}
-.endif
-
LISPDIR= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
.if !defined(NOPORTDOCS)
@@ -58,4 +53,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${EMACS_PORT_NAME} != "emacs23"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/uim-el/Makefile b/textproc/uim-el/Makefile
index 5bbc11659e95..7e29344a75fb 100644
--- a/textproc/uim-el/Makefile
+++ b/textproc/uim-el/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uim-el
PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX= -${EMACS_PORT_NAME}