aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /textproc
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'textproc')
-rw-r--r--textproc/2bsd-diff/Makefile8
-rw-r--r--textproc/htmldoc/Makefile2
-rw-r--r--textproc/libextractor/Makefile2
-rw-r--r--textproc/qt4-clucene/Makefile1
-rw-r--r--textproc/qt4-xml/Makefile1
-rw-r--r--textproc/qt4-xmlpatterns-tool/Makefile1
-rw-r--r--textproc/qt4-xmlpatterns/Makefile1
-rw-r--r--textproc/re_graph/Makefile10
-rw-r--r--textproc/sphinxsearch/Makefile2
9 files changed, 6 insertions, 22 deletions
diff --git a/textproc/2bsd-diff/Makefile b/textproc/2bsd-diff/Makefile
index 5138a66c08ea..7dfc2b9dba24 100644
--- a/textproc/2bsd-diff/Makefile
+++ b/textproc/2bsd-diff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: 2bsd-diff
-# Date created: Mon Mar 17 20:54:03 EST 2003
-# Whom: risner@stdio.com
-#
+# Created by: risner@stdio.com
# $FreeBSD$
-#
PORTNAME= diff
PORTVERSION= 2.11
@@ -17,7 +13,7 @@ DISTNAME= file8
MAINTAINER= risner@stdio.com
COMMENT= 2.11BSD diff utility
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - bin/diff man/man1/diff.1
+EXTRACT_AFTER_ARGS= bin/diff man/man1/diff.1
WRKSRC= ${WRKDIR}/bin/diff
MAN1= 2diff.1
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index 032ad8822524..cf51e8520b46 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-localjpeg --enable-localzlib --enable-localpng
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
EXCLUDE= png jpeg zlib htmldoc/md5* htmldoc/rc4* htmldoc/snprintf*
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - ${EXCLUDE:S,^,--exclude ,}
+EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
MAN1= htmldoc.1
post-patch:
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index b2f07617e5c5..21f737cf084c 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -22,7 +22,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude libltdl
+EXTRACT_AFTER_ARGS= --exclude libltdl
MAN1= extract.1
MAN3= libextractor.3
diff --git a/textproc/qt4-clucene/Makefile b/textproc/qt4-clucene/Makefile
index 59d788fc6133..c559cef68d51 100644
--- a/textproc/qt4-clucene/Makefile
+++ b/textproc/qt4-clucene/Makefile
@@ -30,7 +30,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/xmlpatterns src/3rdparty/freetype src/3rdparty/libjpeg \
src/3rdparty/libmng src/3rdparty/libpng src/3rdparty/libtiff \
src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 60fcdc45dd97..d9ebb917e232 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -30,7 +30,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/textproc/qt4-xmlpatterns-tool/Makefile b/textproc/qt4-xmlpatterns-tool/Makefile
index 1c59ef10c5c9..916b11a2fb3d 100644
--- a/textproc/qt4-xmlpatterns-tool/Makefile
+++ b/textproc/qt4-xmlpatterns-tool/Makefile
@@ -29,7 +29,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/textproc/qt4-xmlpatterns/Makefile b/textproc/qt4-xmlpatterns/Makefile
index de27356dd6b7..a39442379a03 100644
--- a/textproc/qt4-xmlpatterns/Makefile
+++ b/textproc/qt4-xmlpatterns/Makefile
@@ -30,7 +30,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
src/3rdparty/libpng src/3rdparty/libtiff src/3rdparty/phonon \
src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/textproc/re_graph/Makefile b/textproc/re_graph/Makefile
index 36aa9631cac1..b86040b8120d 100644
--- a/textproc/re_graph/Makefile
+++ b/textproc/re_graph/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: re_graph
-# Date created: Apr 22, 2005
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= re_graph
PORTVERSION= 0.2
@@ -21,9 +16,6 @@ RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
p5-GD-Arrow>=0:${PORTSDIR}/graphics/p5-GD-Arrow
NO_WRKSUBDIR= yes
-EXTRACT_CMD= ${TAR}
-EXTRACT_BEFORE_ARGS= -xf
-EXTRACT_AFTER_ARGS= # empty
NO_BUILD= yes
USE_PERL5_RUN= yes
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index c5e140e367e3..0294c319e79d 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -158,7 +158,7 @@ DOCSRC= ${WRKSRC}/doc
post-extract:
.if ${PORT_OPTIONS:MLIBSTEMMER}
@( cd ${WRKSRC} && \
- ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${LIBSTEMMER_TGZ} \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${LIBSTEMMER_TGZ} \
${EXTRACT_AFTER_ARGS} )
.endif