aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-21 17:15:39 +0800
committermiwi <miwi@FreeBSD.org>2009-10-21 17:15:39 +0800
commit2121d6d5b4dc2a5b1f29ec608266ed1526fdb01b (patch)
tree647a9e9ebb3eba1ee969454c306a7a8841399dc1 /textproc
parent049a028ebc8c58a728b4921878aeec333833937b (diff)
downloadfreebsd-ports-gnome-2121d6d5b4dc2a5b1f29ec608266ed1526fdb01b.tar.gz
freebsd-ports-gnome-2121d6d5b4dc2a5b1f29ec608266ed1526fdb01b.tar.zst
freebsd-ports-gnome-2121d6d5b4dc2a5b1f29ec608266ed1526fdb01b.zip
This is a keyboard for input of the Malayalam according to the transliteration
scheme called Mozhi (https://sites.google.com/site/cibu/mozhi). The keymap is written in Keyman keyboard language and developed as a part of Varamozhi Project under the LGPL license. The Mozhi is intended to be the most intuitive scheme for Malayalam speakers. It simplifies what the user needs to remember and is is not phonetically accurate. This keymap supports the current standard for Malayalam Chillus (i.e. without special encoding). It offers mnemonic keyboard functionality and smart-quote functionality with comas and numerals. This port installs the keyboard so that it can be used through SCIM KMFL IMEngine (textproc/scim-kmfl-imengine). WWW: http://varamozhi.sourceforge.net/ PR: ports/139498 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/kmfl-varamozhi-malayalam/Makefile52
-rw-r--r--textproc/kmfl-varamozhi-malayalam/distinfo3
-rw-r--r--textproc/kmfl-varamozhi-malayalam/pkg-descr17
-rw-r--r--textproc/scim-kmfl-varamozhi-malayalam/Makefile52
-rw-r--r--textproc/scim-kmfl-varamozhi-malayalam/distinfo3
-rw-r--r--textproc/scim-kmfl-varamozhi-malayalam/pkg-descr17
7 files changed, 145 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7661a8208c88..4e7e4f3aee26 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1075,6 +1075,7 @@
SUBDIR += scim-kmfl-sil-ipa-unicode5
SUBDIR += scim-kmfl-sil-panafrican-latin
SUBDIR += scim-kmfl-sil-yi
+ SUBDIR += scim-kmfl-varamozhi-malayalam
SUBDIR += scim-m17n
SUBDIR += scim-openvanilla
SUBDIR += scim-table-imengine
diff --git a/textproc/kmfl-varamozhi-malayalam/Makefile b/textproc/kmfl-varamozhi-malayalam/Makefile
new file mode 100644
index 000000000000..30cc8014dee7
--- /dev/null
+++ b/textproc/kmfl-varamozhi-malayalam/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: scim-kmfl-varamozhi-malayalam
+# Date created: 10 October 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-kmfl-varamozhi-malayalam
+PORTVERSION= 1.1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/varamozhi/2%20Mozhi%20Keyman%20-%20Input%20Method/${PORTVERSION} \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/kmfl/
+DISTNAME= mozhi_${PORTVERSION}
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= SCIM KMFL IMEngine Malayalam keyboard according to the Mozhi scheme
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+USE_DOS2UNIX= mozhi_1.1.0.kmn
+NO_BUILD= yes
+USE_ZIP= yes
+
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PLIST_FILES= ${SCIM_KMFL_DIR}/mozhi_1.1.0.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/mozhi.bmp
+
+post-patch:
+ @${REINPLACE_CMD} -E 's|(Mozhi Keymap 1\.1\.1)|Varamozhi \1|' \
+ ${WRKSRC}/mozhi_1.1.0.kmn
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+ @${ECHO_MSG}
+ @${ECHO_MSG} " At the moment, this keyboard has no downloadable"
+ @${ECHO_MSG} " documentation. For the details on the Mozhi scheme,"
+ @${ECHO_MSG} " please see the Project's homepage, especially"
+ @${ECHO_MSG} " https://sites.google.com/site/cibu/mozhi."
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/kmfl-varamozhi-malayalam/distinfo b/textproc/kmfl-varamozhi-malayalam/distinfo
new file mode 100644
index 000000000000..65522ce3a7bc
--- /dev/null
+++ b/textproc/kmfl-varamozhi-malayalam/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/mozhi_1.1.1.zip) = 69eb4fd5405c5fbed69bc401a48bef67
+SHA256 (kmfl/mozhi_1.1.1.zip) = b1d584c60ecde1c2c40ca96945bf062be5d32d52249570328cd112f9f29037f1
+SIZE (kmfl/mozhi_1.1.1.zip) = 208053
diff --git a/textproc/kmfl-varamozhi-malayalam/pkg-descr b/textproc/kmfl-varamozhi-malayalam/pkg-descr
new file mode 100644
index 000000000000..f002ba048e3f
--- /dev/null
+++ b/textproc/kmfl-varamozhi-malayalam/pkg-descr
@@ -0,0 +1,17 @@
+This is a keyboard for input of the Malayalam according to the transliteration
+scheme called Mozhi (https://sites.google.com/site/cibu/mozhi). The keymap is
+written in Keyman keyboard language and developed as a part of Varamozhi
+Project under the LGPL license.
+
+The Mozhi is intended to be the most intuitive scheme for Malayalam speakers.
+It simplifies what the user needs to remember and is is not phonetically
+accurate.
+
+This keymap supports the current standard for Malayalam Chillus (i.e. without
+special encoding). It offers mnemonic keyboard functionality and smart-quote
+functionality with comas and numerals.
+
+This port installs the keyboard so that it can be used through SCIM KMFL
+IMEngine (textproc/scim-kmfl-imengine).
+
+WWW: http://varamozhi.sourceforge.net/
diff --git a/textproc/scim-kmfl-varamozhi-malayalam/Makefile b/textproc/scim-kmfl-varamozhi-malayalam/Makefile
new file mode 100644
index 000000000000..30cc8014dee7
--- /dev/null
+++ b/textproc/scim-kmfl-varamozhi-malayalam/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: scim-kmfl-varamozhi-malayalam
+# Date created: 10 October 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-kmfl-varamozhi-malayalam
+PORTVERSION= 1.1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/varamozhi/2%20Mozhi%20Keyman%20-%20Input%20Method/${PORTVERSION} \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/kmfl/
+DISTNAME= mozhi_${PORTVERSION}
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= SCIM KMFL IMEngine Malayalam keyboard according to the Mozhi scheme
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+USE_DOS2UNIX= mozhi_1.1.0.kmn
+NO_BUILD= yes
+USE_ZIP= yes
+
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PLIST_FILES= ${SCIM_KMFL_DIR}/mozhi_1.1.0.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/mozhi.bmp
+
+post-patch:
+ @${REINPLACE_CMD} -E 's|(Mozhi Keymap 1\.1\.1)|Varamozhi \1|' \
+ ${WRKSRC}/mozhi_1.1.0.kmn
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+ @${ECHO_MSG}
+ @${ECHO_MSG} " At the moment, this keyboard has no downloadable"
+ @${ECHO_MSG} " documentation. For the details on the Mozhi scheme,"
+ @${ECHO_MSG} " please see the Project's homepage, especially"
+ @${ECHO_MSG} " https://sites.google.com/site/cibu/mozhi."
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-kmfl-varamozhi-malayalam/distinfo b/textproc/scim-kmfl-varamozhi-malayalam/distinfo
new file mode 100644
index 000000000000..65522ce3a7bc
--- /dev/null
+++ b/textproc/scim-kmfl-varamozhi-malayalam/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/mozhi_1.1.1.zip) = 69eb4fd5405c5fbed69bc401a48bef67
+SHA256 (kmfl/mozhi_1.1.1.zip) = b1d584c60ecde1c2c40ca96945bf062be5d32d52249570328cd112f9f29037f1
+SIZE (kmfl/mozhi_1.1.1.zip) = 208053
diff --git a/textproc/scim-kmfl-varamozhi-malayalam/pkg-descr b/textproc/scim-kmfl-varamozhi-malayalam/pkg-descr
new file mode 100644
index 000000000000..f002ba048e3f
--- /dev/null
+++ b/textproc/scim-kmfl-varamozhi-malayalam/pkg-descr
@@ -0,0 +1,17 @@
+This is a keyboard for input of the Malayalam according to the transliteration
+scheme called Mozhi (https://sites.google.com/site/cibu/mozhi). The keymap is
+written in Keyman keyboard language and developed as a part of Varamozhi
+Project under the LGPL license.
+
+The Mozhi is intended to be the most intuitive scheme for Malayalam speakers.
+It simplifies what the user needs to remember and is is not phonetically
+accurate.
+
+This keymap supports the current standard for Malayalam Chillus (i.e. without
+special encoding). It offers mnemonic keyboard functionality and smart-quote
+functionality with comas and numerals.
+
+This port installs the keyboard so that it can be used through SCIM KMFL
+IMEngine (textproc/scim-kmfl-imengine).
+
+WWW: http://varamozhi.sourceforge.net/