aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2008-04-24 00:02:00 +0800
committergabor <gabor@FreeBSD.org>2008-04-24 00:02:00 +0800
commit428903faaa4332c1d7ea2d1db99db26fd71ee75d (patch)
tree1f8958e8e88f8da3d58ae921be6a206f6aec3270 /textproc
parent5a27e05a4858e5c6415d3650d908bce53d4abc7a (diff)
downloadfreebsd-ports-gnome-428903faaa4332c1d7ea2d1db99db26fd71ee75d.tar.gz
freebsd-ports-gnome-428903faaa4332c1d7ea2d1db99db26fd71ee75d.tar.zst
freebsd-ports-gnome-428903faaa4332c1d7ea2d1db99db26fd71ee75d.zip
- Fix checking on LaTeX files on amd64
- Bump PORTREVISION PR: ports/122581 Submitted by: Roland Smith <rsmith@xs4all.nl> Approved by: Janos Mohacsi <mohacsi@niif.hu> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/hunspell/Makefile1
-rw-r--r--textproc/hunspell/files/patch-src_parsers_latexparser.cxx11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index bf86e0b28563..1aebb4b18ae0 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hunspell
PORTVERSION= 1.2.2b
+PORTREVISION= 1
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
${MASTER_SITE_SOURCEFORGE:S@$@:data@:S@%SUBDIR%@magyarispell@}
diff --git a/textproc/hunspell/files/patch-src_parsers_latexparser.cxx b/textproc/hunspell/files/patch-src_parsers_latexparser.cxx
new file mode 100644
index 000000000000..89c6b60bed1b
--- /dev/null
+++ b/textproc/hunspell/files/patch-src_parsers_latexparser.cxx
@@ -0,0 +1,11 @@
+--- src/parsers/latexparser.cxx.orig 2008-04-23 17:56:27.000000000 +0200
++++ src/parsers/latexparser.cxx 2008-04-23 17:57:00.000000000 +0200
+@@ -82,7 +82,7 @@
+ { { "\\url", NULL } , 1 }
+ };
+
+-#define PATTERN_LEN (sizeof(PATTERN) / ((sizeof(char *) * 2) + sizeof(int)))
++#define PATTERN_LEN (sizeof(PATTERN) / sizeof(PATTERN[0]))
+
+ LaTeXParser::LaTeXParser(const char * wordchars)
+ {