aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2007-03-22 17:41:43 +0800
committerijliao <ijliao@FreeBSD.org>2007-03-22 17:41:43 +0800
commit493e7bbccd46abd50b9c2c1276d27bf9105988be (patch)
tree0cabeec2aec3399c6d8d4f0058a8376e8f3949d0 /textproc
parentf295ac74ba8912d636563b4f63e9b350baf3f566 (diff)
downloadfreebsd-ports-gnome-493e7bbccd46abd50b9c2c1276d27bf9105988be.tar.gz
freebsd-ports-gnome-493e7bbccd46abd50b9c2c1276d27bf9105988be.tar.zst
freebsd-ports-gnome-493e7bbccd46abd50b9c2c1276d27bf9105988be.zip
add scss 0.2.3
A Scheme module for W3C Cascading Stylesheets recommendation
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/scss/Makefile37
-rw-r--r--textproc/scss/distinfo3
-rw-r--r--textproc/scss/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 83c95c1693db..7e20f8c47bc8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -860,6 +860,7 @@
SUBDIR += scim-table-imengine
SUBDIR += scr2txt
SUBDIR += scrollkeeper
+ SUBDIR += scss
SUBDIR += sdcv
SUBDIR += sdf
SUBDIR += sdocbook-xml
diff --git a/textproc/scss/Makefile b/textproc/scss/Makefile
new file mode 100644
index 000000000000..2feaaed346eb
--- /dev/null
+++ b/textproc/scss/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: SCSS
+# Date created: Mar 22, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= scss
+PORTVERSION= 0.2.3
+CATEGORIES= textproc scheme
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A Scheme module for W3C Cascading Stylesheets recommendation
+
+RUN_DEPENDS= guile:${PORTSDIR}/lang/guile
+
+NO_BUILD= yes
+
+FILES= lexer.scm parser.scm scss.scm
+PLIST_FILES= share/guile/scss/lexer.scm \
+ share/guile/scss/parser.scm \
+ share/guile/scss/scss.scm
+PLIST_DIRS= share/guile/scss
+
+INFO= scss
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/guile/scss
+.for f in ${FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/guile/scss
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/scss.info ${PREFIX}/info
+
+.include <bsd.port.mk>
diff --git a/textproc/scss/distinfo b/textproc/scss/distinfo
new file mode 100644
index 000000000000..05f2285e25ff
--- /dev/null
+++ b/textproc/scss/distinfo
@@ -0,0 +1,3 @@
+MD5 (scss-0.2.3.tar.gz) = 1e2d3e38cd662bb191741bdf3ed54d66
+SHA256 (scss-0.2.3.tar.gz) = 06c29ed314d3d7c62cd19d29bcec4db73b16580d6f6e7ef8f177d1a5462bc47d
+SIZE (scss-0.2.3.tar.gz) = 65633
diff --git a/textproc/scss/pkg-descr b/textproc/scss/pkg-descr
new file mode 100644
index 000000000000..6d82255f84ea
--- /dev/null
+++ b/textproc/scss/pkg-descr
@@ -0,0 +1,9 @@
+SCSS is a Scheme module for parsing, querying, and emitting style information
+compatible with the W3C Cascading Stylesheets recommendation. While SCSS does
+not itself provide any rendering functionality, it can provide style
+information to applications and libraries that do. If used with XML documents
+produced by SXML or SDOM, SCSS can accomodate the full range of selector types
+described in the W3C recommendation; it can also match simple selectors against
+strings when structured document information is not available.
+
+WWW: http://www.nongnu.org/scss/