aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2004-07-02 03:59:02 +0800
committerlth <lth@FreeBSD.org>2004-07-02 03:59:02 +0800
commit542fbc1fcda33272873cd13487e30035eb856b72 (patch)
tree953f3f5c7b8f265bc1e136a475eccba6dbbb8259 /textproc
parentb2689b34afbcd83f822dfafc8848e2c33df2d529 (diff)
downloadfreebsd-ports-gnome-542fbc1fcda33272873cd13487e30035eb856b72.tar.gz
freebsd-ports-gnome-542fbc1fcda33272873cd13487e30035eb856b72.tar.zst
freebsd-ports-gnome-542fbc1fcda33272873cd13487e30035eb856b72.zip
Update to 2.12
PR: 68046 Approved by: maintainer timeout, erwin (implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-XML-Simple/Makefile12
-rw-r--r--textproc/p5-XML-Simple/distinfo4
-rw-r--r--textproc/p5-XML-Simple/files/5.005_03-lib::XML::Simple.pm41
3 files changed, 53 insertions, 4 deletions
diff --git a/textproc/p5-XML-Simple/Makefile b/textproc/p5-XML-Simple/Makefile
index 5c2668df44e9..771cc292891d 100644
--- a/textproc/p5-XML-Simple/Makefile
+++ b/textproc/p5-XML-Simple/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML-Simple
-PORTVERSION= 2.09
+PORTVERSION= 2.12
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@@ -22,4 +22,12 @@ PERL_CONFIGURE= YES
MAN3= XML::Simple.3 XML::Simple::FAQ.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+EXTRA_PATCHES= ${PATCHDIR}/5.005_03-lib::XML::Simple.pm
+
+post-configure:
+ ${PERL} -pi -e 's/(\(POD2MAN_EXE\))/$$1 --lax/' ${WRKSRC}/Makefile
+
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Simple/distinfo b/textproc/p5-XML-Simple/distinfo
index e37e36a79cba..015ed1352bd9 100644
--- a/textproc/p5-XML-Simple/distinfo
+++ b/textproc/p5-XML-Simple/distinfo
@@ -1,2 +1,2 @@
-MD5 (XML-Simple-2.09.tar.gz) = 7138184cbfe3c1d26c98ff55690a679d
-SIZE (XML-Simple-2.09.tar.gz) = 59459
+MD5 (XML-Simple-2.12.tar.gz) = 001884c8f2f9ccbee61e5e72547309ad
+SIZE (XML-Simple-2.12.tar.gz) = 65543
diff --git a/textproc/p5-XML-Simple/files/5.005_03-lib::XML::Simple.pm b/textproc/p5-XML-Simple/files/5.005_03-lib::XML::Simple.pm
new file mode 100644
index 000000000000..a1ef3ce58a01
--- /dev/null
+++ b/textproc/p5-XML-Simple/files/5.005_03-lib::XML::Simple.pm
@@ -0,0 +1,41 @@
+--- lib/XML/Simple.pm.orig Mon Apr 5 09:12:47 2004
++++ lib/XML/Simple.pm Thu Jun 17 13:41:37 2004
+@@ -331,7 +331,7 @@
+ if($filename) {
+ # $tree = $xp->parsefile($filename); # Changed due to prob w/mod_perl
+ local(*XML_FILE);
+- open(XML_FILE, '<', $filename) || croak qq($filename - $!);
++ open(XML_FILE, '<'. $filename) || croak qq($filename - $!);
+ $tree = $xp->parse(*XML_FILE);
+ close(XML_FILE);
+ }
+@@ -541,9 +541,9 @@
+ }
+ else {
+ local(*OUT);
+- open(OUT, '>', "$self->{opt}->{outputfile}") ||
++ open(OUT, '>'. "$self->{opt}->{outputfile}") ||
+ croak "open($self->{opt}->{outputfile}): $!";
+- binmode(OUT, ':utf8') if($] >= 5.008);
++# binmode(OUT, ':utf8') if($] >= 5.008);
+ print OUT $xml || croak "print: $!";
+ close(OUT);
+ }
+@@ -1535,7 +1535,7 @@
+ sub numeric_escape {
+ my($self, $data, $level) = @_;
+
+- use utf8; # required for 5.6
++# use utf8; # required for 5.6
+
+ if($self->{opt}->{numericescape} eq '2') {
+ $data =~ s/([^\x00-\x7F])/'&#' . ord($1) . ';'/gse;
+@@ -1569,7 +1569,7 @@
+ my @keys = $self->{opt}->{nosort} ? keys %$hashref : sort keys %$hashref;
+ foreach $key (@keys) {
+ $value = $hashref->{$key};
+- return($hashref) unless(UNIVERSAL::isa($value, 'HASH'));
++ return($hashref) unless(UNIVERSAL::isa($value||'', 'HASH'));
+
+ if(ref($self->{opt}->{keyattr}) eq 'HASH') {
+ return($hashref) unless(defined($self->{opt}->{keyattr}->{$parent}));