aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-10-03 17:25:42 +0800
committerkwm <kwm@FreeBSD.org>2010-10-03 17:25:42 +0800
commit5c521a9b0214a969f3fd4dc28da4aed20f59a1da (patch)
tree7f4cea2fea968c9300c49f2fed943077913bef89 /textproc
parenta2e671e80f81d994f27500acc69819428df4369c (diff)
downloadfreebsd-ports-gnome-5c521a9b0214a969f3fd4dc28da4aed20f59a1da.tar.gz
freebsd-ports-gnome-5c521a9b0214a969f3fd4dc28da4aed20f59a1da.tar.zst
freebsd-ports-gnome-5c521a9b0214a969f3fd4dc28da4aed20f59a1da.zip
Use libtool in c++ mode instead of c mode, to link C++ code.
This fixes the build with clang. Submitted by: rene@
Diffstat (limited to 'textproc')
-rw-r--r--textproc/rarian/files/patch-util_Makefile.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/textproc/rarian/files/patch-util_Makefile.in b/textproc/rarian/files/patch-util_Makefile.in
new file mode 100644
index 000000000000..2a84a36e8ab4
--- /dev/null
+++ b/textproc/rarian/files/patch-util_Makefile.in
@@ -0,0 +1,15 @@
+--- util/Makefile.in.orig 2010-10-03 11:23:55.000000000 +0200
++++ util/Makefile.in 2010-10-03 11:24:58.000000000 +0200
+@@ -401,10 +401,10 @@
+ done
+ rarian-example$(EXEEXT): $(rarian_example_OBJECTS) $(rarian_example_DEPENDENCIES)
+ @rm -f rarian-example$(EXEEXT)
+- $(LINK) $(rarian_example_OBJECTS) $(rarian_example_LDADD) $(LIBS)
++ $(CXXLINK) $(rarian_example_OBJECTS) $(rarian_example_LDADD) $(LIBS)
+ rarian-sk-gen-uuid$(EXEEXT): $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_DEPENDENCIES)
+ @rm -f rarian-sk-gen-uuid$(EXEEXT)
+- $(LINK) $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_LDADD) $(LIBS)
++ $(CXXLINK) $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_LDADD) $(LIBS)
+ rarian-sk-get-cl$(EXEEXT): $(rarian_sk_get_cl_OBJECTS) $(rarian_sk_get_cl_DEPENDENCIES)
+ @rm -f rarian-sk-get-cl$(EXEEXT)
+ $(rarian_sk_get_cl_LINK) $(rarian_sk_get_cl_OBJECTS) $(rarian_sk_get_cl_LDADD) $(LIBS)