aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-02-15 22:34:26 +0800
committermiwi <miwi@FreeBSD.org>2016-02-15 22:34:26 +0800
commit790e7372b009ecab418d9e694794df6a87b97fce (patch)
tree921070ae859847e6ad2f11168de4014a9c3571e8 /textproc
parentf8b583cc4f758cfd2ed8b667d74bb0fd222e0392 (diff)
downloadfreebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.tar.gz
freebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.tar.zst
freebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.zip
Welcome php 7.0.3
Changelog: http://php.net/ChangeLog-7.php#7.0.0 http://php.net/ChangeLog-7.php#7.0.1 http://php.net/ChangeLog-7.php#7.0.2 http://php.net/ChangeLog-7.php#7.0.3 I'd like to thanks: Kurt Jaeger Matthias Breddin Rainer Duffner Victor van Vlaardingen Torsten Zuehlsdorff Franco Fichtner and all helpers and testers from ports@.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile9
-rw-r--r--textproc/php70-ctype/Makefile10
-rw-r--r--textproc/php70-dom/Makefile10
-rw-r--r--textproc/php70-pspell/Makefile10
-rw-r--r--textproc/php70-simplexml/Makefile10
-rw-r--r--textproc/php70-simplexml/files/patch-config.m443
-rw-r--r--textproc/php70-wddx/Makefile10
-rw-r--r--textproc/php70-wddx/files/patch-config.m422
-rw-r--r--textproc/php70-wddx/files/patch-wddx.c40
-rw-r--r--textproc/php70-xml/Makefile10
-rw-r--r--textproc/php70-xml/files/patch-compat.c13
-rw-r--r--textproc/php70-xmlreader/Makefile10
-rw-r--r--textproc/php70-xmlwriter/Makefile10
-rw-r--r--textproc/php70-xsl/Makefile10
-rw-r--r--textproc/php70-xsl/files/patch-php_xsl.h11
15 files changed, 228 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8c02c9a31c0b..cde2b97424e7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1183,6 +1183,15 @@
SUBDIR += php56-xmlreader
SUBDIR += php56-xmlwriter
SUBDIR += php56-xsl
+ SUBDIR += php70-ctype
+ SUBDIR += php70-dom
+ SUBDIR += php70-pspell
+ SUBDIR += php70-simplexml
+ SUBDIR += php70-wddx
+ SUBDIR += php70-xml
+ SUBDIR += php70-xmlreader
+ SUBDIR += php70-xmlwriter
+ SUBDIR += php70-xsl
SUBDIR += plover
SUBDIR += po4a
SUBDIR += pocketreader
diff --git a/textproc/php70-ctype/Makefile b/textproc/php70-ctype/Makefile
new file mode 100644
index 000000000000..f6833afb0e77
--- /dev/null
+++ b/textproc/php70-ctype/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -ctype
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-dom/Makefile b/textproc/php70-dom/Makefile
new file mode 100644
index 000000000000..9c5b18115755
--- /dev/null
+++ b/textproc/php70-dom/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -dom
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-pspell/Makefile b/textproc/php70-pspell/Makefile
new file mode 100644
index 000000000000..a2978e35831b
--- /dev/null
+++ b/textproc/php70-pspell/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -pspell
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-simplexml/Makefile b/textproc/php70-simplexml/Makefile
new file mode 100644
index 000000000000..a4d88cb47a12
--- /dev/null
+++ b/textproc/php70-simplexml/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -simplexml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-simplexml/files/patch-config.m4 b/textproc/php70-simplexml/files/patch-config.m4
new file mode 100644
index 000000000000..4eeef697dc87
--- /dev/null
+++ b/textproc/php70-simplexml/files/patch-config.m4
@@ -0,0 +1,43 @@
+--- config.m4.orig 2014-05-14 10:14:22.929420181 +0000
++++ config.m4 2014-05-14 10:15:36.967414693 +0000
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(simplexml, whether to enable SimpleXML support,
+ [ --disable-simplexml Disable SimpleXML support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir SimpleXML: pcre install prefix], no, no)
++
+ if test -z "$PHP_LIBXML_DIR"; then
+ PHP_ARG_WITH(libxml-dir, libxml2 install dir,
+ [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
+@@ -11,6 +14,30 @@
+
+ if test "$PHP_SIMPLEXML" != "no"; then
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
+ fi
diff --git a/textproc/php70-wddx/Makefile b/textproc/php70-wddx/Makefile
new file mode 100644
index 000000000000..87bab097e937
--- /dev/null
+++ b/textproc/php70-wddx/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -wddx
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-wddx/files/patch-config.m4 b/textproc/php70-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php70-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php70-wddx/files/patch-wddx.c b/textproc/php70-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php70-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else
diff --git a/textproc/php70-xml/Makefile b/textproc/php70-xml/Makefile
new file mode 100644
index 000000000000..6eca62cf06a7
--- /dev/null
+++ b/textproc/php70-xml/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -xml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-xml/files/patch-compat.c b/textproc/php70-xml/files/patch-compat.c
new file mode 100644
index 000000000000..02125961b20c
--- /dev/null
+++ b/textproc/php70-xml/files/patch-compat.c
@@ -0,0 +1,13 @@
+--- compat.c.orig Tue Jul 20 10:55:02 2004
++++ compat.c Tue Jul 20 10:55:55 2004
+@@ -16,6 +16,10 @@
+ +----------------------------------------------------------------------+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #if defined(HAVE_LIBXML) && defined(HAVE_XML) && !defined(HAVE_LIBEXPAT)
+ #include "expat_compat.h"
diff --git a/textproc/php70-xmlreader/Makefile b/textproc/php70-xmlreader/Makefile
new file mode 100644
index 000000000000..dd5701bb7584
--- /dev/null
+++ b/textproc/php70-xmlreader/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -xmlreader
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-xmlwriter/Makefile b/textproc/php70-xmlwriter/Makefile
new file mode 100644
index 000000000000..7827d75cd84b
--- /dev/null
+++ b/textproc/php70-xmlwriter/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -xmlwriter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-xsl/Makefile b/textproc/php70-xsl/Makefile
new file mode 100644
index 000000000000..7096247682e7
--- /dev/null
+++ b/textproc/php70-xsl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -xsl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php70-xsl/files/patch-php_xsl.h b/textproc/php70-xsl/files/patch-php_xsl.h
new file mode 100644
index 000000000000..9777187f8748
--- /dev/null
+++ b/textproc/php70-xsl/files/patch-php_xsl.h
@@ -0,0 +1,11 @@
+--- php_xsl.h.orig Sun Jan 1 13:50:17 2006
++++ php_xsl.h Tue Jan 17 16:23:10 2006
+@@ -43,7 +43,7 @@
+ #include <libexslt/exsltconfig.h>
+ #endif
+
+-#include "../dom/xml_common.h"
++#include "ext/dom/xml_common.h"
+ #include "xsl_fe.h"
+
+ #include <libxslt/extensions.h>