aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-04-28 17:03:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-04-28 17:03:22 +0800
commit830139df1787957313b9c37f2b5d1c6189d95ce7 (patch)
tree562ce2ee59427b302faa38948ef8cc4182d6d52f /textproc
parent602c1e1050946930ac7d4f1756a5019bde3ee6b5 (diff)
downloadfreebsd-ports-gnome-830139df1787957313b9c37f2b5d1c6189d95ce7.tar.gz
freebsd-ports-gnome-830139df1787957313b9c37f2b5d1c6189d95ce7.tar.zst
freebsd-ports-gnome-830139df1787957313b9c37f2b5d1c6189d95ce7.zip
- Add LICENSE
- Switch to USES=tar - Add NO_ARCH - Switch to options helpers - Pet portlint
Diffstat (limited to 'textproc')
-rw-r--r--textproc/re_graph/Makefile14
-rw-r--r--textproc/re_graph/pkg-descr24
2 files changed, 21 insertions, 17 deletions
diff --git a/textproc/re_graph/Makefile b/textproc/re_graph/Makefile
index f929d7a162f7..3b342f48bb51 100644
--- a/textproc/re_graph/Makefile
+++ b/textproc/re_graph/Makefile
@@ -7,27 +7,31 @@ PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://www.oualline.com/sw/re/
DISTNAME= ${PORTNAME:S/_/-/}_${PORTVERSION:S/.//}
-EXTRACT_SUFX= .tar
MAINTAINER= ports@FreeBSD.org
COMMENT= Regular Expression Graphing Program
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
RUN_DEPENDS= p5-GD>=0:graphics/p5-GD \
p5-GD-Arrow>=0:graphics/p5-GD-Arrow
-USES= perl5
+USES= tar perl5
+USE_PERL5= run
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_PERL5= run
+NO_ARCH= yes
PLIST_FILES= bin/re_graph
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-PORTDOCS= *
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/re_graph.pl ${STAGEDIR}${PREFIX}/bin/re_graph
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/re_graph.html ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/tut* ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/re_graph/pkg-descr b/textproc/re_graph/pkg-descr
index 9b9901414afd..195f1ed9ea8d 100644
--- a/textproc/re_graph/pkg-descr
+++ b/textproc/re_graph/pkg-descr
@@ -1,17 +1,17 @@
The re_graph.pl program graphs regular expressions. The guts of the regular
-expression engine is a simple state machine. The various states and operations
-in the regular expression parser can be displayed using a surprisingly simple
-diagram.
+expression engine is a simple state machine. The various states and
+operations in the regular expression parser can be displayed using a
+surprisingly simple diagram.
A few notes on what you are looking at:
- * The nodes Start and Stop denote the beginning and end of the regular
- expression.
- * The solid squares denote atoms. Lines indicate the next state. When a
- line splits, the state machine will take the top line first. If it's
- path is blocked it will backup and take the next lower line. This is
- repeated until it finds a path to the end or all paths are exhausted.
- * Brown boxes indicate a grouping operation, i.e. ().
- * Green boxes indicate a zero with test. The state machine will perform the
- test inside the box before moving ahead.
+ * The nodes Start and Stop denote the beginning and end of the regular
+ expression.
+ * The solid squares denote atoms. Lines indicate the next state. When a
+ line splits, the state machine will take the top line first. If it's
+ path is blocked it will backup and take the next lower line. This is
+ repeated until it finds a path to the end or all paths are exhausted.
+ * Brown boxes indicate a grouping operation, i.e. ().
+ * Green boxes indicate a zero with test. The state machine will perform
+ the test inside the box before moving ahead.
WWW: http://www.oualline.com/sw/