aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /textproc
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/gmetadom/Makefile2
-rw-r--r--textproc/libmrss/Makefile2
-rw-r--r--textproc/scim-openvanilla/Makefile4
-rw-r--r--textproc/soothsayer/Makefile4
-rw-r--r--textproc/xmlwrapp/Makefile2
5 files changed, 7 insertions, 7 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index 8bfdaf3ad7ad..556457492d3b 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -16,7 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}b
MAINTAINER= ports@FreeBSD.org
COMMENT= A Collection of DOM Implementations
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= gdome.8:${PORTSDIR}/textproc/gdome2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,6 +25,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
OPTIONS= OCAML "OCAML language support" off
diff --git a/textproc/libmrss/Makefile b/textproc/libmrss/Makefile
index 13a27fcc528f..5ff41eb27853 100644
--- a/textproc/libmrss/Makefile
+++ b/textproc/libmrss/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://www.autistici.org/bakunin/libmrss/
MAINTAINER= clsung@FreeBSD.org
COMMENT= A C library for parsing, writing, and creating RSS
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
nxml.18:${PORTSDIR}/textproc/libnxml
@@ -25,6 +24,7 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
WANT_GNOME= yes
pre-patch:
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index b048ef24f636..3524cb8776c7 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
- ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+ ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -27,6 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USE_GMAKE= yes
USE_GETTEXT= yes
USE_ICONV= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= OV_MODULEDIR=${PREFIX}/lib/openvanilla/
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index 723c948d1823..007fd0e3ffcc 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= # none known, please fix
MAINTAINER= ports@FreeBSD.org
COMMENT= Intelligent predictive text entry platform
-BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
USE_SQLITE= 3
USE_AUTOTOOLS= libtool
@@ -25,6 +24,7 @@ CONFIGURE_ENV= ac_cv_path_CPPUNIT_CONFIG=no \
ac_cv_prog_HAVE_DOXYGEN=no
CONFIGURE_ARGS= --disable-python-binding
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAN1= soothsayer_demo.1 soothsayer_demo_text.1 \
soothsayer_simulator.1 text2ngram.1
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index 8c9ebcbc2eba..cdf6479ba079 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -17,7 +17,6 @@ COMMENT= A modern style C++ library for working with XML data
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= boost_iostreams.4:${PORTSDIR}/devel/boost-libs
OPTIONS= XSLT "build libxsltwrap library (requires libxslt)" off
@@ -27,6 +26,7 @@ USE_PERL5_BUILD=yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include