aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-23 13:20:21 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-23 13:20:21 +0800
commit8a7eae061561418e35a59db38d16ba303560ff67 (patch)
tree4c3a8e2ad7f2b233e613c9951242b37143037b00 /textproc
parent779d02e01d4f8529df3ba36e1087f1efd3d6a701 (diff)
downloadfreebsd-ports-gnome-8a7eae061561418e35a59db38d16ba303560ff67.tar.gz
freebsd-ports-gnome-8a7eae061561418e35a59db38d16ba303560ff67.tar.zst
freebsd-ports-gnome-8a7eae061561418e35a59db38d16ba303560ff67.zip
- Convert to new options framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/confget/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/textproc/confget/Makefile b/textproc/confget/Makefile
index ed1d0a672472..017810fb8eed 100644
--- a/textproc/confget/Makefile
+++ b/textproc/confget/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://devel.ringlet.net/textproc/confget/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Read variables from INI-style configuration files
-OPTIONS= PCRE "Regular expression support" on
+OPTIONS_DEFINE= EXAMPLES PCRE
+OPTIONS_DEFAULT=PCRE
MAKE_ENV= CFLAGS_CONF=-DHAVE_FGETLN
USE_GMAKE= yes
@@ -24,24 +25,24 @@ MANCOMPRESSED= yes
PLIST_FILES= bin/confget
PORTEXAMPLES= t1.ini t2.ini
-.if !defined(NOPORTEXAMPLES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
.endif
-.include <bsd.port.options.mk>
-
-.if !defined(WITHOUT_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
.else
MAKE_ENV+= PCRE_CFLAGS="" PCRE_LIBS=""
.endif
post-patch:
-.if defined(NOPORTEXAMPLES)
+.if empty(${PORT_OPTIONS:MEXAMPLES})
@${REINPLACE_CMD} -e '/^install:/ s| install-examples||' ${WRKSRC}/Makefile
.endif
regression-test test: build
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.mk>