aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-05-07 17:34:39 +0800
committerwjv <wjv@FreeBSD.org>2002-05-07 17:34:39 +0800
commit98203839b07f20af81492627d05d1ae1fc3a2895 (patch)
tree86b15a508d8fd46cfe2be1ec2c2ab5958d474c9d /textproc
parent59fe06100b17261b9ac2411c68e6d8b6098a2bf3 (diff)
downloadfreebsd-ports-gnome-98203839b07f20af81492627d05d1ae1fc3a2895.tar.gz
freebsd-ports-gnome-98203839b07f20af81492627d05d1ae1fc3a2895.tar.zst
freebsd-ports-gnome-98203839b07f20af81492627d05d1ae1fc3a2895.zip
- Update to version 0.7.1
- Various small style fixes - Updated pkg-descr PR: 37744 (0.7.1 update) Submitted by: Hye-Shik Chang <perky@fallin.lv>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-xml/Makefile10
-rw-r--r--textproc/py-xml/distinfo2
-rw-r--r--textproc/py-xml/pkg-descr25
-rw-r--r--textproc/py-xml/pkg-plist24
4 files changed, 28 insertions, 33 deletions
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index dfb959983282..5241134e0091 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xml
-PORTVERSION= 0.7
+PORTVERSION= 0.7.1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pyxml
@@ -15,10 +15,6 @@ DISTNAME= PyXML-${PORTVERSION}
MAINTAINER= wjv@FreeBSD.org
-INSTALLS_SHLIB= yes
-# On a system with more than one version of Python installed, you can force
-# this port to install for a specific version of Python by explicitly setting
-# ${PYTHON_VERSION} during build/installation.
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -37,10 +33,10 @@ post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for docfile in ANNOUNCE CREDITS LICENCE README* TODO
- @ ${INSTALL_MAN} ${WRKSRC}/${docfile} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
@ cd ${WRKSRC}/doc && find * \
- | ${CPIO} ${MANOWN}:${MANGRP} ${DOCSDIR}
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
@ ${MKDIR} ${EXAMPLESDIR}
@ cd ${WRKSRC} && find demo test \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
diff --git a/textproc/py-xml/distinfo b/textproc/py-xml/distinfo
index 7b4a2571b2ec..b58fac74c95c 100644
--- a/textproc/py-xml/distinfo
+++ b/textproc/py-xml/distinfo
@@ -1 +1 @@
-MD5 (PyXML-0.7.tar.gz) = d22e8f7e423833e5f5a9a9d3d2395c73
+MD5 (PyXML-0.7.1.tar.gz) = 6a2e7f0b95961b08dab95b0416cebf9d
diff --git a/textproc/py-xml/pkg-descr b/textproc/py-xml/pkg-descr
index b5fc8953a8b8..dbbb18767220 100644
--- a/textproc/py-xml/pkg-descr
+++ b/textproc/py-xml/pkg-descr
@@ -1,12 +1,23 @@
-This is the Python XML package. The distribution contains a
-validating XML parser, an implementation of the SAX and DOM
-programming interfaces, an interface to the Expat parser (and the
-Expat parser itself), and a C helper module that can speed up
-xmllib.py by a factor of 5. There's even documentation!
+From the website:
-The current version is still to be considered a beta release.
+ The PyXML package is a collection of libraries to process XML with Python.
+ It contains, among other things
-WWW: http://www.python.org/sigs/xml-sig/
+ - xmlproc: a validating XML parser
+ - sgmlop: a C helper module that can speed-up xmllib.py and sgmllib.py by
+ a factor of 5
+ - PySAX: SAX 1 and SAX2 libraries with drivers for most of the parsers
+ - 4DOM: A fully compliant DOM Level 2 implementation
+ - javadom: An adapter from Java DOM implementations to the standard Python
+ DOM binding
+ - pulldom: a DOM implementation that supports lazy instantiation of nodes
+ - marshal: a module with several options for serializing Python objects to
+ XML, including WDDX and XML-RPC
+ - unicode: a helper module for Python 1.5 users who need conversions
+ between UTF-8 and ISO-8859-?
+
+WWW: http://www.pyxml.sourceforge.net/
+See also: http://www.python.org/sigs/xml-sig/
-- Jacques Vidrine <nectar@FreeBSD.ORG> (original port)
-- Johann Visagie <wjv@FreeBSD.org> (current maintainer)
diff --git a/textproc/py-xml/pkg-plist b/textproc/py-xml/pkg-plist
index 9207f4cf3910..b7b857577d8c 100644
--- a/textproc/py-xml/pkg-plist
+++ b/textproc/py-xml/pkg-plist
@@ -100,6 +100,7 @@
%%PORTDOCS%%share/examples/py-xml/demo/xmlproc/xbel2html.py
%%PORTDOCS%%share/examples/py-xml/demo/xmlproc/xpcmd.py
%%PORTDOCS%%share/examples/py-xml/demo/xmlproc/xvcmd.py
+%%PORTDOCS%%share/examples/py-xml/test/doc.xml
%%PORTDOCS%%share/examples/py-xml/test/dom/TestSuite.py
%%PORTDOCS%%share/examples/py-xml/test/dom/borrowed/TestSuite.py
%%PORTDOCS%%share/examples/py-xml/test/dom/borrowed/af_20000919.py
@@ -201,27 +202,14 @@
%%PORTDOCS%%share/examples/py-xml/test/dom/test_struct.py
%%PORTDOCS%%share/examples/py-xml/test/dom/test_text.py
%%PORTDOCS%%share/examples/py-xml/test/dom/test_treewalker.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/Base.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/CoreLvl1.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/CoreLvl2.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/CoreLvl3.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/Load3.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/TraversalLvl2.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/XMLLvl1.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/XMLLvl2.py
-%%PORTDOCS%%share/examples/py-xml/test/domapi/__init__.py
%%PORTDOCS%%share/examples/py-xml/test/enc_test.xml
-%%PORTDOCS%%share/examples/py-xml/test/output/.#test_c14n.1.1
%%PORTDOCS%%share/examples/py-xml/test/output/test_c14n
%%PORTDOCS%%share/examples/py-xml/test/output/test_dom
-%%PORTDOCS%%share/examples/py-xml/test/output/test_domu
%%PORTDOCS%%share/examples/py-xml/test/output/test_encodings
%%PORTDOCS%%share/examples/py-xml/test/output/test_howto
%%PORTDOCS%%share/examples/py-xml/test/output/test_htmlb
%%PORTDOCS%%share/examples/py-xml/test/output/test_javadom
%%PORTDOCS%%share/examples/py-xml/test/output/test_marshal
-%%PORTDOCS%%share/examples/py-xml/test/output/test_marshal.orig
-%%PORTDOCS%%share/examples/py-xml/test/output/test_marshal.rej
%%PORTDOCS%%share/examples/py-xml/test/output/test_minidom
%%PORTDOCS%%share/examples/py-xml/test/output/test_parsers
%%PORTDOCS%%share/examples/py-xml/test/output/test_pyexpat
@@ -231,13 +219,13 @@
%%PORTDOCS%%share/examples/py-xml/test/output/test_sax_xmlproc
%%PORTDOCS%%share/examples/py-xml/test/output/test_saxdrivers
%%PORTDOCS%%share/examples/py-xml/test/output/test_utils
+%%PORTDOCS%%share/examples/py-xml/test/output/test_xmlproc
%%PORTDOCS%%share/examples/py-xml/test/quotes.xml
%%PORTDOCS%%share/examples/py-xml/test/regrtest.py
%%PORTDOCS%%share/examples/py-xml/test/test.xml
%%PORTDOCS%%share/examples/py-xml/test/test.xml.out
%%PORTDOCS%%share/examples/py-xml/test/test_c14n.py
%%PORTDOCS%%share/examples/py-xml/test/test_dom.py
-%%PORTDOCS%%share/examples/py-xml/test/test_domu.py
%%PORTDOCS%%share/examples/py-xml/test/test_encodings.py
%%PORTDOCS%%share/examples/py-xml/test/test_howto.py
%%PORTDOCS%%share/examples/py-xml/test/test_htmlb.py
@@ -252,6 +240,7 @@
%%PORTDOCS%%share/examples/py-xml/test/test_sax_xmlproc.py
%%PORTDOCS%%share/examples/py-xml/test/test_saxdrivers.py
%%PORTDOCS%%share/examples/py-xml/test/test_utils.py
+%%PORTDOCS%%share/examples/py-xml/test/test_xmlproc.py
%%PORTDOCS%%share/examples/py-xml/test/testxml.py
%%PORTDOCS%%share/examples/py-xml/test/unittest.py
%%PORTDOCS%%share/examples/py-xml/test/xmlval_illformed.dtd
@@ -263,9 +252,6 @@ lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/FtCore.pyo
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/__init__.pyo
-lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/_checkversion.py
-lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/_checkversion.pyc
-lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/_checkversion.pyo
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/Attr.py
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/Attr.pyc
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/Attr.pyo
@@ -343,6 +329,9 @@ lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/domreg.py
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/domreg.pyc
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/domreg.pyo
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/en_US/LC_MESSAGES/4Suite.mo
+lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Dom2Sax.py
+lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Dom2Sax.pyc
+lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Dom2Sax.pyo
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Printer.py
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Printer.pyc
lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/ext/Printer.pyo
@@ -1011,7 +1000,6 @@ lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/xslt/minisupport.pyo
@dirrm lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom/de
@dirrm lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/dom
%%PORTDOCS%%@dirrm share/examples/py-xml/test/output
-%%PORTDOCS%%@dirrm share/examples/py-xml/test/domapi
%%PORTDOCS%%@dirrm share/examples/py-xml/test/dom/html
%%PORTDOCS%%@dirrm share/examples/py-xml/test/dom/ext
%%PORTDOCS%%@dirrm share/examples/py-xml/test/dom/borrowed